Magic Earth Cannot connect to the General Magic Store

Dear all,

I have been for a few months the owner of a refurbished Galaxy S7 that came with /e/ preinstalled; present OS version is 0.7-2020010636667.

I remember trying the pre-installed Magic Earth app, and getting the same error message as others have reported in this forum in the period August-September 2019. I had not pursued this back then. I recently noted that I can now open this app (presumably something was fixed in an update), and I got interested again. I however now get another error, which I haven’t seen documented. Maybe someone can help…

Basically, when I open the app, with Map Styles set to Standard, I get the map of the world with the country names, but nothing else. If I zoom in, it’s just blank. If I click on the download button, I get the message

Cannot connect to the General Magic Store
Mobile Data is Turned Off
Turn on mobile data or use Wi-Fi to access data.

I am on a wireless, not on mobile data. I tried to have the Setting Mobile Data On and Off, it does not seem to make a difference. Also, when I go to Support and tap on Tips & Tricks, I get the further error

Web page not available
… could not be loaded because:

I should add that I could download and use this app on my google android tablet, on the same wireless, without problem.

Has someone had the same problem? Even better, has someone a solution?

Thanks and best wishes,


Can you check which Magic Earth version you have ?

There was an issue with the version that was bundled with the refurbished S7 in july/august. I think it was fixed now.
I use Aurora Store to get more up to date application versions. You can also try to update it this way. It’s available on the /e/ store.

1 Like

Many thanks for the reply.

My Magic Earth’s version is

I have downloaded Aurora Store, and I will try as you suggest, as soon as I have troubleshooted the next problem: Aurora Store does not let me log in anonymously, although it looks like it should be possible.

Best wishes,

hi @achu i know that General Magic , who makes the Magic Earth app, is in the process of a big update of their app and the GM server, so perhaps that is the reason. Perhaps give it some time, and over the next few weeks this bug will be ironed out.

Good to know.

Thank you both. I’ll give it a bit of time then!
Best wishes,