Magic earth freezes on v.1.21 - S7 edge


Magic earth doesn’t work anymore on my Samsung S7edge (1.21) since updating to 1.20.

The localisation works but as I start moving it doesn’t follow me and freezes at the starting point. I disabled Advanced Privacy, updated the app, and it still doesn’t work.
I guess it is the app because the gps is Ok : I tried Waze instead and it works well.

Any idea? will this be fixed on the next updates ? Or is possible to downgrade to 1.17 that I used just before 1.20 ?

I really dont’t want to continue using waze :grin:

Thank you!

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

It is often worth Clearing Cache after an update.

If this does not help try Clear Storage, but this will cause a “Fresh start” with Maps.

Settings - Apps - See all … apps - Maps - Storage - Clear Cache.

MagicEarth is Version 1.27. You should install an Update

for one user ME ( in /e/ v1.19) freezed because maps were stored on sdcards. Does this relate to you in anyway?

Yes I tried, it still freezes…

Magic Earth on murena 1.21