Magic earth no longer knows my location

I updated my teracube 2e to the 1.0 version of the OS magic earth which worked before no longer knows my location. When I opened the app it also asked to do a map update which I did. If I ask for directions it does not show my location but pulls a location I set, since the phone was showing me in Zurich, I put in a California city. As I move closer to my destination Magic Earth keeps showing the California city not where I am. Magic Earth has location permission. Magic Earth version is

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello @john-mark - the behaviour your describe is likely to be related to the new features in the Advanced Privacy settings.
Here you can hide your real location to apps. One downside of hiding the real location: a navigation app such as Magic Earth does not work properly anymore.

  • Go to: Settings > Advanced Privacy > Manage my location
  • Select: Use my real location
    Within a few instances your device should start working as you expect it.

i have same problem with magic earth - it assumes i’m in manilla
however it seems the gps works, waze sees me on the right location in prague

same settings for both apps

This was observed by several forum users in connection with the introduction of Advanced Privacy.
The post above yours doesn’t apply?

unfortunately didn’t helped - if it didn’t work in waze also i would be blaming the hw, but it was working in waze without any other change in settings

There is a bug that has been reported prior for Fairphone 3 FP3/FP3+

This issue is planned to be resolved for v1.1. If this describes your problem and you do NOT have a Fairphone 3/3+, please do not hesitate to write a quick comment into the bug tracker. Thanks.

1 Like

Following the info you provided. I adjusted my location to my real location. Maps works now, thank you

1 Like

Still not solved on Galaxy S7 with /e/ 1.1. please fix asap

Thanks. Now Magic Earth finds me again. Fake location was on the Philipines, dont know how plausible this is.

Same problem, magic earth no GPS.
I put on my real positon, but it locates me in America.
What is curious is that in Advanced Privacy settings, manage my position, on the map, it turns and does not find my position either.

On Redmi Note 7.

I have found that when testing location with Magic Earth it makes a big difference if you do this testing out of doors (GPS is probably not received indoors) and when you are in motion. Best still if you switch wifi and mobile data signals while out on a little expedition (for instance using WiFi at a cafe, library, bus or train).

/e/OS relies on two “backends” to improve the collection of location data from transmissions to your device.

Please check the location settings of your “Backends”

Use the search facility in Settings, search for backends; you should find two

  • Mozilla UnifiedNlp Backend
  • Nominatum Geocoder Backend

In my case I also installed from App Lounge a third backend Local NLP Backend, which helped get correct location more quickly more often.


Open and check under Permissions that location is allowed for both UnifiedNlp Backend and Local NLP Backend, if you chose to install it.

1 Like

Thank you for your answer.
I found Mozilla UnifiedNlp Backend and in location it says “Always allow.”
But, it also says “No access logged.” I cleared the cache and will test tomorrow.

For Nominatum Geocoder Backend it says in “Authorization” No authorization requested and I can’t open it.

I will install Local NLP Backend to see if that helps.
Thanks a lot.

Actually I see the same.

More things I have found significant,

  1. (especially if Magic Earth might have spent some time under the influence of Fake my Location in Advanced Privacy) is the setting of Home in Favourites, found from the search bar. If set unset it. When out on an expedition, now set Maps to navigate to your address. Assuming Maps succeeds in “following your progress” then set your Home location when Maps is showing you at the correct place.

  2. I mentioned mobile data, I think it is important to have it switched on

  3. In some areas I have seen it reported on the forum that it is necessary to have your correct map downloaded. The download icon is at the foot of the screen in certain views.

Later edit

It may. of course, not be a problem with Magic Earth but with – perhaps worth reviewing the guide, especially Fake My Location.

In earlier versions of Advanced Privacy it was necessary to restart the phone to ensure that changes take effect. You might experiment with the changing between all options, including Use specific location. Please tell us if the small Mapbox feature within Fake My Location is the faulty component.

Thank you, it works now.

Great job.