Magic Earth not working


Got a Samsung S9 from e and maps has locked up.

Won’t update maps over network. Tried to update using Aurora Apps but APK is invalid. Can’t install or uninstall it. Currently have no maps on phone.

Bit stuck and a bit miffed.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

It’s a known issue and should be solved with next eOS update

OK thanks. So when is that?

I hope, next week …
in the meantime, try OSM from f-droid

1 Like

I can also recommend as a backup solution. It’s certainly not open source, since it’s made by Czech company, but it’s an alternative to Google Maps, is “free”, works better than Magic Earth imo and asks for only very few permissions.

Thank you. I will have a look

I have a related problem, but not as severe as it continues working “as is”:
For a few days now, after starting it, “Magic Earth” shows a hint that I should update it to keep it compatible with the newer on- and offline maps. Using the app-store, there is no announcement that it can be updated, it can only be started. Am I just too stupid, coming from BlackBerry or is it lagging the current version?
Will this also be fixed with the next /e/ update?

That’s similar to me but additionally I can’t use any of the maps in areas I’ve not visited because I can’t download them. Whole app has locked up, more to the point I can’t delete it easily either.

Very disappointing that such a significant function doesn’t work. I knew e would be a compromise of functionality and I was prepared to accept that, but it’s not acceptable to buy a product which is more expensive and then have constant bugs and syncing issues.

If you’re worried about privacy then the pay off for better privacy appears to be worse reliability. In its current state sadlyI could not recommend e to a non savvy user.

I can feel you. And the bug was known over a month.

Has anyone tested “magig earth” with the new /e/ reelase (0.12p) already?
I’m currently afraid of updating because I need the phone for urgent calls theses days.

On my FP3 it works … at least while testing it out for several seconds (also with navigating)