Magisk root with /e/OS 1.9 impossible

I am a bit disappointed that I cannot root my Fairphone 4 with /e/OS 1.9. Magisk patch will result in a bootloop… I’ve also tried .zip file method and such on magisk website

Magisk used to work with previous versions of /e/, so I guess it’s somehow related to a recent change in boot.img

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Did you try flashing the zip in ADB? That works on my OnePlus 9.

I tried also ADB. But i’ve now solved the problem with rebooting in safe mode (volume down pushed while the e. is on screen). I think it was linked to a module ( Android auto magisk module likely )

I am wanting to root my fp4 too. I am on 1.9 too.

Could ylu post step by step instruction how you did it without bricking?

For example i need to patch thr image file. Which image? /e/ 1.9 image or the stock fairphone image? For 1.9 which file needs patched?

What needs flashed and how?

Thanks in advance

All custom ROM development teams I know that offer a custom ROM including a relocking bootloader advise against rooting because it is counterproductive for security.

Locking the bootloader is important because it allows for a fully verified boot. A rooted ROM, on the other hand, compromises all security measures and opens the door and gate to attackers.

If you are on stock 1.9, you just have to follow the steps here : h*tps://

  • grab the zip file in h*tps:// unzip it and copy boot.img to your phone
  • install magisk apk from here : h*tps://
  • patch the boot.img file from Magisk app, copy from download to your computer
  • install ADB and fastboot on your computer : ht*ps://
  • type on a command line " adb reboot bootloader "
  • while on bootloader, type " adb flash boot path to your boot_magiskxxxxxx.img" ( the patched file you copied to your computer )
  • done :slight_smile:
  • enjoy and don’t update OTA, this could break Magisk :slightly_frowning_face:
    If you experience brick, you just have to flash back original boot.img :ok_hand:

Oh I forget, do you have unlocked bootloader ? If not, go there :


Yes, that’s true but why they don’y allow locking bootloader AND root ? You need root for various operations ( adblocking, android auto, Xprivacylua… in my case ). I think root can improve privacy.

Well, man’s faith is his kingdom. But the fact is: with Google’s convenient Android Auto comes a complete abandonment of privacy.

Rooting disables some of the OS’s built-in security features that are part of keeping the OS secure and your data safe from exposure or corruption. Anything that reduces the internal controls in the Android operating system poses a higher risk. Why probably offers no renovated custom ROM developer a factory-rooted device?

Well, you MIGHT give up a little on security, but you WIN big time in terms of privacy, no more adds, freedom to mock and adjust settings, use charging control which is good for your battery life, not to mention Xposed with all its benefits. All that, to me, is way more important than a closed bootloader. But hey, that’s personal :slight_smile:

I think you may misunderstood what I said. Android auto is closed source, so yes, using it don’t improve privacy. But with root, you can mock google TTS, google voice, google maps and other crap software required by Android Auto. You can use Osm based maps. So yes, privacy improvement.

I think a google engineer may say same words. Okay, you can do less things, but it’s for your security. I prefer freedom ( and that’s personal, as said by Infintity )

This topic was automatically closed after 7 days. New replies are no longer allowed.