Mail app and IMAP

The Mail app do not update the status of new email. Normally if I read a new mail on a desktop client all my devices change this email to read. But in Mail it stays as unread until I do tap on it. This is not cool. Is their a setting to change or is it a known problem?

Have you checked you account setting in email app ?

I have just tried. I have send me an email to my account. When I have gotten the push message notification on my device I opened rainloop via web browser on laptop. On laptop I opened the email. Than I opened the mail client on my device and the email was shown as read.
So everything is fine

I just checked all settings but did not find anything to change.
I have about eight email account installed with imap and not one is changing the status of the email that I read on an other device or on my laptop. And yes between the same accounts installed on other device it mark the email as read if I read it somewhere else.
Just not with Mail from /e/

I have made a second test with hotmail.

  1. Have send a mail from proton to hotmail

  2. In email app it shows greyed (unread)

  3. I have opened the mail on browser/

  4. I have refreshed email app and email was shown normal (read)

  5. I have done the same in the other direction with same result

Have you enabled this option?

By the way, I’m using eOS pie with this email version

I have the same mail version!

In my e account I have sync mail switched off. This because I directly sync my mails with my provider. Without going over my self hosted nextcloud account. This should not be a problem.

It must be an issue with your provider / setup. Because with and hotmail all works fine.

I disagree, because it also works with all other apps and desktops On other systems. The problem is Only with mail.
But I will do some more testings and maybe try an other email app.

you can try the original K9 email client. Would be interesting if it will work there

But I still think it must be something on your setup because on 2 tested provider it is working fine.
May I ask you at which provider it isn’t working? So I can try? Or is it goolag?

Is the standard mail a k9 or only a from from k9?

Yes I think something is not set properly on my phone.

I found the problem and as expected it’s a user based problem. My stupidity is the cause of it.
I do apologise and want to say that everything ist doing as it should. :slight_smile:

thx for letting me know. What was the root cause ??

Stupidity :laughing:
Because I’m moving slowly out of google, I created new email addresses and setup a forward mail for all email that are coming in my old inbox. On /e/ I installed only the new email accounts which received all fresh email from gmail. On my Mac and iOS i’ still have my gmail account and I was reading mails from this account. So I was wondering why on my eOs the messages were still not read. But it clear why, gmail forwarded it to my new mail and couldn’t mark them as read.
As I said this was stupidity :frowning: :no_mouth:

Ah, OK, no problem. Everything clear now for me.

Sometimes everyone makes a dumb mistake :wink:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.