Make USB-Stick accessible

I recently tried to display a pdf-file on my FP3 and learned that I cannot access my USB-Stick.
That was quite awkward out of reasons.
It does simply not show up beneath the internal storage and the flashdisk card, though I use a fiting USB-USB-C cable.

Possible trouble sources:

  • Wrong format? (FAT)
  • May this eventually not be a OTG-adapter (nothing written on it)?
  • Or is anything else relevant?

While I do not know if this is the reason, I have actually found my USB-stick (it has both a USB-C and a USB-A plug) works much better on my FP3+ since v2.0 and having just checked, it is formatted as ExFAT. If my memory is right, I chose ExFAT to maximize compatibility with my other hardware.

Well, I am curious.
Just formatted the stick exFAT and put a simple *.jpg on it.
To no avail: It still is absent on the phone either using the storage section of settings or an app to show files.

1 Like

I think there is still some magic connected with OTG. Any device you plug in to rely on, mostly seems to need to be sold as OTG or Android compatible. I have two work fine, but I notice users who write in with difficulties often talk of “cable connected”. Having said that I have experimented with a small low cost OTG adapter and found it worked sometimes but not always.

Well, this still leaves me wondering.
Things that work are willingly accepted, but for me it doesn’t work.

I checked with two USB-OTG checkers, both say that my device is ready for it, but it has to be activated in the settings.
I do not find any.
GRMBL.

what version are you on? though I think FP3 should have exFAT support since long

Might that be USB Debugging in Settings > System > Developer Options? :thinking:

(If Developer Options aren’t visible/accessible for you yet, go to Settings > About phone > Build number and tap on this seven times.)

You can also try connecting another phone to your OTG, using a standard cable.
I use that with my Xiaomies, to transfert files (apk mostly).

I am installing RCs regularily, so dev-opts are known.
Nope, doesn’t work for me.
No reaction, no showing-up.