Many Libre Office files coming up read only

I have a number of Libre Office apps, but many are coming up as read only, but I wish to update. How can I change odt files from read to read/write?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Do you mean mail attachments while they are still attached? Attachments are mostly read only (depends on the mail client).

More Details needed to help


I had a number of Word and Pages documents on my iPhone. As I am now moving from iOS to e/OS, and MacOS to Elementary OS and Microsoft Office to Libre Office, I converted the files to odt files. I didn’t select save as read only.

Is there a way on the phone to assign read/write privileges to the files, or will I need to do that on the computer?


You could install a proper file manager like Total Commander to change file permissions easily. I’m afraid you will not be very successful using the stock Files app for that.

What app are you using to open the .odt files? Did you already try Collabora Online for Android?

Thanks irrlicht,

I downloaded the app, looks good.

When I go into change permissions it is

ticked R(ead), W(rite) for both Owner and Group, but nothing for world. What’s the X for? Deletable?

What does the 660 mean?

What to do now?


Hi spipau,

I am using Callabora offline.




Thanks kisman172,

So why are apps such as collabora saying the files are read only?

Do I need to tick R & W in world?

What does execute mean in this context?

Sorry if I am asking stupid questions, just trying to understand.

An APP must be executable not a document

I don’t use callabora office, don’t know it, and don’t want to install it for testing, sorry

maybe try opendocument reader in F-droid

Well, I tried changing the properties of the offending documents, saved, said applied tried to open and edit, no luck. Went back into properties and they had reset themselves to what they were before I changed them.

I found AndrOpen Office, that opens and modifies all my docs, ignores any read only labels (if there are any).

It is just a reader. How do you want to check writeable? :wink:

1 Like

So, thats your solution? Fixed?

Two apps say some files are read only.

I can’t find how to change their settings on the phone, but this app opens and allows you to edit (and its editing is the best that I have seen on a mobile device). Ideally I would be able find out why these files are coming up as read only on the phone, but it looks like I will have to use my computer to get full properties of the files, and if I can’t fix them I will recreate them.

Try to copy the files somewhere else. On UNIX systems also the permissions on the containing directory are important. If you don’t have write access to the directory you probably get problems writing files, at least creating new files or deleting existent files will not be possible. And that really happens, many apps save their files not by overwriting but by creating a new file and then deleting the old one. LibreOffice creates (on my PC) also a temporary second file (the lock file) beside the document file while it is edited. When the lock file can’t be created the document can’t be edited.

Another idea: Are you on the SD card? Has your Office full access to the SD card? Try to edit the files while they are in a directory on the device internal memory.

BTW: The x-bit in the permissions means “execute”. That is for executable files including shell (and other) scripts. On the other hand it controls whether you can enter a directory or not. Directories without the x-bit are rare.

Thanks irrlicht, I will give it a try.