Maybe bricked 2 Moto G7 River? Need help

With help here I have now installed Lake on several G7 Plus (Lake) but I am stuck trying on a G7 (XT1962-1) River. I have two with similar problem. I have them both unlocked but I can’t get TWRP to run. In the instructions it was the last of the 3 fastboot install/boot combinations that seemed to work but for an error or warning about image not signed or corrupt. I tried 2 versions of TWRP.

jv@Balsamo:~/proj/e/g7river$ fastboot flash boot twrp-3.5.2_10-0-river.img
(bootloader) is-logical:boot_a: not found
Sending ‘boot_a’ (6 KB) OKAY [ 0.169s]
Writing ‘boot_a’ (bootloader) Image not signed or corrupt
OKAY [ 0.030s]
Finished. Total time: 0.201s

but… booting to recovery or now even normal start gives me something like this:

Essentially bricked but at least I can still communicate with fastboot.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Thanks. I am failing at step 14. It gets an error at the booting part.

UPDATE: I should have checked my SHA first, wget mangled the TWRP image. I fixed that and have correct images but still getting the same error with no progress in the procesure.

UPDATE 2: With the good TWRP it worked as expected and I got /e/ installed! But the first one is still stuck.
Not sure what I did to get to this state on one but not the other?

are you able to restore back to stock, and start from scratch ?..

I don’t see how to do that. I can’t get into any of the fastboot sub menus. Is there another method or something (I am still a n00b at this).



No experience of this, but I think this phone has 2 slots. Try this article.

and some further background reading here,

1 Like

@newts am the one who wrote the instructions mentioned earlier. I have had a number of issues during the process and have worked out the problems. I am going to send you a personal message.


UPDATE: I went to check the model of the phone and just for fun I tried the FACTORY option again and this time it booted to TWRP. I have no idea how or why and it came up looking for a user password that I canceled out of.
When I get back home tonight I will see if I can now continue with the sideloads of the partitions hack and the /e/ install.


UPDATE Working! Once I was in TWRP I did the wipes, the copy-partitions, and the /e/ sideload and now I have it going.

Thanks again for the help and offer for more.


So happy it worked. Enjoy it.