Media Player stuck with Spotify

Hey all,

I am facing an issue with the build-in media player when using Spotify.
This issue started with the S-Version of /e/OS. Right now I am using 1.17-s-20231113351092-dev-nio. Spotify recevied some updates through the usage. Currently I am running Version 8.9.6.458 of the Spotify App.

When the device is booted freshly and I start Spotify the first time for this boot the Media Player is displaying the correct title infromation of the song, pause and skip button are working as well. Both in lockscreen and in control center.
After I close the Spotify App the Media Player is stuck at the last played song. Reopening Spotify (or e.g. the build-in Music App) cannot access the Media Player anyone. No progress is shown, played song does not get updated, pause and play button are not working.
After rebooting the issue appears after the first time closing the Spotify App. Also tried it with the Music App. Quitting the Music App does not make the Player get stuck.

Once the Media Player stuck at a song bluetooth devices like cars or headphones are not able to skip songs, pause tracks and displaying the title of the song that was played when Spotify was closed no matter what track is being played.

In addition I used every possible configuration of the media player settings but the behavior has not changed. In the settings you can find “Fix Media Player” and “Show recommedations” which both can be activated or deactivated.

With /e/OS version e-1.8.1-r-20230206257804-dev-nio everything worked fine. This issue occured after upgrading to e-1.15-s-20230917331435-dev-nio. I did every update since then but there has not been a fix yet.

Anybody facing this issue as well or has some suggestion on how to fix it?

1 Like

Hey,

I am facing the same issue. Everything as you described. This is pretty annoying especially when you are driving =/

cheers,

I have this problem too! the play/pause functions work fine, but the progress and all the song info are stuck

Same here. It continues to work somehow after force-closing spotify.

It’s especially annoying when running and trying to control playlists via external controls…