MEGA App Stops with /e/ 0.92020051554230

Hello,

I would like to know if anybody else is experiencing the same issue with the MEGA app since the last update. For me, it starts, then updates the file list, and just when you think that everything seems to be working fine, it stops. I have tried to clear the cache and program data, but without any luck. The same behavior is seen on both my Oneplus One and a Fairphone 2.

Thanks for your help!

Mgns

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I have same issue on a FP3.
Updates are available. Click on it ans download. Once downloaded, appli crashes ans phone goes back to home screen.
Same behaviour when selecting “uodate all” or selecting appli zone by one.

@PKT, he was talking about the MEGA cloud storage app, you seem to be referring to something else. The Apps store maybe?

Anyway, I haven’t updated to 0515 yet so can’t check the issue. I’m not one to update every time a new build is available. Given that there hasn’t been any changelogs available since early March I never know if I should update or not.

I’ll update tomorrow and see what happens.

@marcdw You’re correct, my problem is with the MEGA cloud storage application that won’t open correctly since the last update of the /e/OS. Let’s see if you experience the same thing.

@marcdw Hello ! Yes. Sorry for the mistake. I was talking about the App store on FP3. It seems that upgrades are avalaible for some app, but clicking on all or one, download is going and at the end, the App store crashes.

Something strange.
Updates are done.
The FP3 notifies me about 4 appli updates in notification bar.
Following that way, all appli updates are done.

1 Like

On the Nougat device I updated to the latest 0.9 0515 build. My MEGA app is okay. It’s an older v3.0.6 (TeamBlackOut clear version).

I haven’t updated the Pie device yet. I always have bad luck so I gotta do a full backup first. :grin:

@PKT, the Apps store is still having a few issues. Just finished reading a thread about it. Then it crashed on me while just looking around.

Hello,
i’ve just installed /e/ on my Oneplus 3T.

Everything seems to be fine except MEGA app. It keep crashing at startup :frowning:

Anyone with this issue? Any idea?

Thanks!

@marcdw Glad to hear that it worked on your Nougat device. Maybe its to early to say if it’s the App, the OS or a combination of both. The MEGA app I have installed is version 3.7.5.

@woodruff It seems to be the same issue as I have. When I start MEGA it seems to load correctly, it goes so far that I can see my cloud files and folders, but only for a second or two. Shortly after that view it crashes and exits. The things I have tried so far hasn’t helped solving the issue.

@Mgns
Okay folks. Did a round of testing once I updated to latest Pie build. The problem is not with /e/ really.

On both Nougat and Pie:
My TBO clear version 3.0.6 GOOD.
Version 3.7.4 GOOD. Latest version shown to me via Aurora/Play Store.
Version 3.7.5 (305) BAD. installed from Apps store. For completeness I also tried build 302 from apkmirror. Same result.

Crash logs show 3.7.5 is trying to invoke some kind of billing manager, i.e. In-App Billing. It’s not a Google thing either. ClassyShark3xodus doesn’t see it as a tracker.
apps_Packages Info does show it has a related permission: com.android.vending.BILLING.

05-20 17:40:55.909  8056  8056 E AndroidRuntime: FATAL EXCEPTION: main
05-20 17:40:55.909  8056  8056 E AndroidRuntime: Process: mega.privacy.android.app, PID: 8056
05-20 17:40:55.909  8056  8056 E AndroidRuntime: java.lang.NullPointerException: Attempt to invoke interface method 'java.util.Iterator java.util.List.iterator()' on a null object reference
05-20 17:40:55.909  8056  8056 E AndroidRuntime: 	at mega.privacy.android.app.utils.billing.BillingManager$5.run(BillingManager.java:332)
05-20 17:40:55.909  8056  8056 E AndroidRuntime: 	at mega.privacy.android.app.utils.billing.BillingManager.executeServiceRequest(BillingManager.java:382)
05-20 17:40:55.909  8056  8056 E AndroidRuntime: 	at mega.privacy.android.app.utils.billing.BillingManager.queryPurchases(BillingManager.java:344)
05-20 17:40:55.909  8056  8056 E AndroidRuntime: 	at mega.privacy.android.app.utils.billing.BillingManager.access$100(BillingManager.java:54)
05-20 17:40:55.909  8056  8056 E AndroidRuntime: 	at mega.privacy.android.app.utils.billing.BillingManager$1.run(BillingManager.java:127)
05-20 17:40:55.909  8056  8056 E AndroidRuntime: 	at mega.privacy.android.app.utils.billing.BillingManager$6.onBillingSetupFinished(BillingManager.java:362)

Continues on few more lines.

Using Blocker and MyAndroidTools I see only one activity with the word “bill” in it. Blocked that as well as other things I usually block. Didn’t help.
3.7.5 introduced a new UI as well.
I suggest sticking with 3.7.4 then test 3.7.6 when it comes out.

Hello!

I apologize for my late reply.

Thanks a lot for that thorough explanation of what could be wrong, I should reserve some time to learn how to do it myself.

Just wanted to let you know that a MEGA update arrived one or two days ago through Apps, and with that, the application works again.

My version now says 3.7.5 (307).

Thanks for your time again!