microG Exposure API not installable on /e/OS 0.18

I have updated to /e/OS 0.18 a few days ago. Since then the microG Exposure API from thr Apps store is not installable on my FP3. Consequentially, the German Corona-Warn-App does not work either on my device, at least the risk assessment feature.

Any help appreciated,

Andreas

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Perhaps this here still helps? …

There is still an active bug that means Apps fails to install the Exposure Notification Framework. That defect specifes a workaround for that is

Workaround

If you are on /dev, download and install microG EN for dev

If you are on /stable, download an install microG EN for stable

All APKs are available at Releases · e / apps / GmsCore · GitLab

According to this response to the defect

Finally, I got it! A patch should be deployed early next week.

The root cause it microG is declared as a persistent app, preventing it to be updated.

I wonder whether that is the same ‘next week’ when we will hear about /e/'s exciting new branding :wink:

4 Likes

Marvin, the developer of microg, has posted a workaround using adb or using a terminal app.

I have tried the adb solution, and it worked (at least on my phone :slight_smile: )
According to Marvin, you seem to need root if you use the terminal app solution.

  • First, download the correct apk as described by @petefoth above.
  • Then, follow Marvin’s instructions. Replace the apk name core-nightly.apk by the name you have given to the apk.
  • Do not forget to reboot (the last command adb reboot in the adb instructions does this).
1 Like