microG service does not allow me to add a Google Account

I’m trying to get casting to a Chromecast to work and some services like Youtube require me to sign in. I’ve never been able to sign in with a Google Account to microG services.

Whenever I get as far as my password and accepting policies, it brings up a message saying “Sorry…there was a problem communicating with Google servers.”
Is this normal? I know the whole point is to avoid registering for Google…but the occasional service keeps asking for it and microG keeps failing to sync the account. Has anyone found as solution to this?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I tried factory resetting my phone and am still receiving “Sorry…there was a problem communicating with Google servers.” Even with no SIM or SD Card inserted.

Removing the SIM/SD and resetting was an old fix for the Vanced microG app. Has anyone had a similar problem add a Google Account with microg? It’s impossible for me.

Hello Kryzzly,

I experience the same issue (on the side of others). I have changed from Galaxy S7 to Terracube 2e, both with the Q-/e/ OS system (indicated on the list of the /e/ foundation) over the last week. I have never experienced any troubles with the Galaxy but the Terracube is a different experience ^^ C’est la vie mais bon! I can not bypass Whatsapp for professional purposes and Youtube Music for the soul.

  1. All setting from the Google account are green, so I don’t think the issue originating from there.

  2. I observed that the microg versions differ (2.25 for the Galaxy; 2.26 for the Terracube). So, I have tried to install the 2.25 on the Terracube but the installation stops to run over the end of the process. The same thing happens with microg 2.27. So, microg being part of the core system; the system must blocks it.

  3. I added the google account on the terracube (which was not mandatory on the Galaxy), nothing. Then, I remove it, nothing.

  4. I tried to force the system by entering the details like a madman again & again for 10 min, nothing!

I was thinking about removing my account from the Galaxy microg supposing it could block the connexion from the terracube. But before that, could please an admin give some advices?

Have a nice week-end!

The microG from upstream has a different signature than the one in /e/OS. You can’t just try and update on top.
Trying to do so manually, especially without a capable recovery (TWRP and the like), is a pain in the rear.

I haven’t had to add a Google account to a device in a long time but a couple of devices (w/microG) do have an account since I have Play Store installed.

I will try now to add an account on the Teracube running 1.7-r and microG 0.2.26 and see what happens.

EDIT: Added Google account without issue. Device registration and GCM are off also but it went without a hitch.

Any way you can capture a log so folks can take a look or a screenshot of where it fails.

EDIT2: Any chance of a network issue, maybe Advanced Privacy’s Hide IP feature? Google login might fail if Tor is in use.

Hello Marc,

Nop, the issue was there before I touch the Advanced Privacy’s settings. I just changed them in case of but it changed anything.

I have uploaded a picture of the message after it fails. It appears straightafter the demand to connect to Google services.

I am going to try to reboot the OS to its very original point (sortie d’usine), then reinstall e. If nothing works, then RIP Terracube, I will go back a Samsung.