Microphones not activated when activating loudspeaker and hands-free mode

Hello all,
I use /e/ os 1.10-s, and I have a very annoying problem I guess everyone may have with fairphone 4 and /e/ os.
When I turn on the loudspeaker during a call, no one can hear me. So I investigated a little bit. Fairphone have 3 mics, one for normal calls, and two other for hands-free call. When I switch to hand free mode, only the bottom mic is working. I tried :

Whatzapp and telegram are perfectly working, so it’s related to system and low level android, I guess…
3 mics are okay if I test with another app, so not hardware related problem… I suspect : com.android.server.telecom to be the root of this problem

Where is the parameter for this annoying problem ?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello Julien,
can confirm that problem using v1.10 on FP4. Several attempts in freehanded calling, but I just can be heard when switching off speakers. Not sure if the problem’s gone when updating onto v1.11.

I hope so… Where can we open an issue in their github ?

It’s not solved in 1.11 and I cannot create a gitlab issue…

Received the v1.11 update OTA yesterday, but had no hand-free phone call since then, so at the moment I can’t confirm or disprove your experience.

It seems strange that no more FP4-users seem to give notice of that problem.

Another way of to point to that problem can be to try to contact @Manoj.

Report an issue or are you Getting an error message in new ID creation on /e/OS Gitlab?