Microsoft 365 Two Factor Authentication


Is there any solution for Microsoft 365 with 2 Factor Authentication? We are using in our Company Microsoft 365 in combination with Cisco Duo, and I can not authentitcate.

Still get this error:

Here are old topics that I found without solution:

Without my company Microsoft 365 Mails / Kalender I can not use /e/os - that would be realy sad.

Thanks for your help

If this is on your private phone: Get a work phone from your employer. You have no obligation to run work stuff on your private phone.

If this is on your work phone: Because of /e/OS’s obvious limitations in Google Services Framework compatibility by design it’s not suited for serious work-related stuff anyway. Even if you could get stuff fixed and working now, it can break again at any moment.
Use the stock OS instead.

Just my two cents.

1 Like

Thanks for your answer AnotherElk. Ok, this answer did not make me happy. I want to have the company mails from my own company on my phone.

So do you mean, there is no solution fĂĽr 2 Factor with Microsoft 365 on /e/os?

Are you trying to login with a Microsoft app or a browser? I don’t run any Microsoft apps on my phone but I do login to the corporate Outlook via a browser. The 2FA works without problems usually. Occasionally there is a problem at the corporate/Microsoft end.

1 Like

Hello, I have tried it with the onboard E-Mail app, the outlook app and also directly through the default web browser.

Ah, you are betting your own business workflows on the functioning of an Android custom ROM. You can of course do this, but I would think this over in light of the current issue.

I don’t want to “put my processes over” a custom ROM system. I simply assumed that 2-factor authentication and Office 365 are so widespread today that there should be a solution. But maybe someone else has an idea.

So I think all this push 2 Factor Software Tokens are not working with microG. Am I correct? Any other solutions?

I dont know if it will work in /e/os and microG situation but in the past I’ve found using Microsoft’s authenticator app purely for o365 worked best. But we also had SSO setup. So maybe that was why it seemed to work seemlessly.

Ok, thanks for answer. The Problem is, that we have Cisco Duo in the Company. We can Not change it

We also have SSO. I use the Aegis app for 2FA.

I have not found any solution to this, importunately.

Very sad to hear. So all people the have to use 2factor with Push (Like Cisco Duo) can Not use /e/os / Murena or have to use 2 phones. (Not comfortable)

This should be solved soon.

Is there really no ability to configure a 2nd 2fa option (printable backup codes, hardware 2fa device plugged to USB port, use of an authenticator app, etc)? What happens if you are traveling and your phone is stolen for example?

Login in Webmail with Firefox is possible. I changed firefox to standard browser, but mail app still not working.

Any ideas?

Update 2:
I generated a webapp with firefox for the outlook wemail and changed the standardbrowser back to sytem browser.

And so this is a great workaround. Outlook looks like an app and is full functional.

1 Like

I use Outlook on my FP4, with several 2FA types. So in MS365, you can have multiple 2FA choices, unless your admin has defined a policy to exclude that. Also, since you mentioned using DUO, you can often use any 2FA in place of DUO (often the site doesn’t care as long as you enter the correct code). I have used FreeOTP+, Proton Pass, Unifi, and even Microsoft’s own Authenticator with success.

Log in on the web, and go to View Account. You’ll see Security Info, and that is where you can make changes. If your MS365 is a GoDaddy or other 3rd Party provided email, it may look slightly different.

On the weekend I will try this, thanks. Until I can use outlook with firefox webapp. Works great until now

This topic was automatically closed after 90 days. New replies are no longer allowed.