Might have bricked my phone while installing /e/ os on FP3? Help?

Hey there,

I’m still troubleshooting this, but am hoping someone can lend me a hand. :slight_smile:
I just bought the Fairphone 3 and followed these instructions to install /e/ os: https://doc.e.foundation/devices/FP3/install

I finished everything and there didn’t seem to be any issues, except that when I rebooted to the new OS (saw the logo and everything) the touchscreen wasn’t working (it was working before on the default phone OS). I restarted it again (and also tried to take the battery in and out), but no go. Now, after another restart the display is completely black. (I see a light indication when plugging it in to charge, and also hear an appropriate sound effect).

Since I locked the bootloader (as the instructions mention) I no longer have access with adb/fastboot from my computer. I can’t see anything and the touchscreen probably isn’t working.

I can’t think of anything else to do, so any help or input would be greatly appreciated. :slight_smile:



Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Power off the phone, press and hold power + vol down until you get in fastboot mode. Does that work?

I’m… unsure.
I did that, and felt/heard the phone vibrate (just like when I reboot it by just pressing the power button).
It’s connected to my computer, adb devices shows nothing, however when I do fastboot -w I get:

Erasing 'userdata' FAILED (remote: 'device is locked. Cannot erase')

Update: I see the device with fastboot devices:
A209L7MR0201 fastboot

…progress? :slight_smile:

To avoid possible trouble with the fastboot command please make sure to use the current Android SDK Platform Tools.

Looking good.

What about fastboot flashing unlock again first?

Just tried that.
Doing fastboot flashing unlock, I get:
OKAY [ 0.081s] Finished. Total time: 0.081s
Then if I reboot the device, I still get a black screen. If I go into fastboot mode again (with power + volume down) and do fastboot -w, I still get:
Erasing 'userdata' FAILED (remote: 'device is locked. Cannot erase') fastboot: error: Command failed

Does fastboot oem 8901_unlock make a difference?

Omg yes! That did the trick. After doing fastboot oem 8901_unlock I was able to do fastboot -w and get:

Erasing 'userdata'                                 OKAY [  0.445s]
mke2fs 1.45.4 (23-Sep-2019)
Creating filesystem with 12777209 4k blocks and 3194880 inodes
Filesystem UUID: 3367c565-b062-4447-a085-8cb41243a240
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 
	4096000, 7962624, 11239424

Allocating group tables: done                            
Writing inode tables: done                            
Creating journal (65536 blocks): done
Writing superblocks and filesystem accounting information: done   

Sending 'userdata' (4661 KB)                       OKAY [  0.160s]
Writing 'userdata'                                 OKAY [  0.052s]
Finished. Total time: 0.863s`

The screen is still black. Should I try to flash again, reboot, or? (I don’t want to do any more damage)

If I got this right your screen is black in Fastboot Mode, too? This would be a concern, it’s not normal.

In this case I would first try to restore the stock OS … https://support.fairphone.com/hc/en-us/articles/360043337512-Install-Fairphone-OS-on-Fairphone-3-using-a-computer

That should show whether the screen not working was a software issue, and it would restore the phone to a well-defined state you can then proceed from again with more certainty.


Yes, that’s true. I will admit my gut tells me this is a hardware issue too.
I’m trying these steps now to install the default FP3 OS, but… if it doesn’t work - am I out of luck? I’m assuming if I contact Fairphone support they’ll tell me I voided the warranty by flashing a new OS, won’t they?

First things first … let’s just see first whether the stock OS installs ok and whether that does something for the screen.

If the screen is still black then, you could still disassemble the display module from the phone and reassemble it to see whether it’s a contact hickup, this procedure doesn’t void the warranty … https://support.fairphone.com/hc/en-us/articles/360032260272-Replace-a-Fairphone-3-module.


Thanks for your encouragement. :slight_smile:

Update: I installed the Fairphone OS and still no go. Now I’m not even sure whether the phone is turned on/off (I don’t get any indication when plugging it in/out of the power supply and the charging light is always off). I tried turning it off/on a few times and no luck.

Going to try reconnecting the display module as you suggested. Will update shortly.

Oi, no go I’m afraid. :frowning:
I disconnected the display module, reconnected it and same effect: black screen, no power light. When I switch the phone on, I get a vibration, but that’s it.

One last try in software: Is the screen staying black if you boot (not install, only boot) the TWRP recovery?
https://twrp.me/fairphone/fairphone3.html … download the IMG file to your computer, then with the phone in Fastboot Mode and connected to the computer fastboot boot filename (substitute filename with the actual filename of the IMG file) and give it about a minute to boot.

Else … If you happen to have Fairphone Angels (volunteer helpers from the Fairphone community) with a Fairphone 3 in your vicinity, you could ask whether it would be possible to test a different display module with your phone to make sure you really (only) have a faulty display.

Else … I guess it would be time to contact Fairphone support to see what they can come up with.
If there were no errors while reinstalling the stock OS, the phone is now in a supported state, and Fairphone couldn’t possibly argue that rebooting the phone or installing /e/ (official partnership and all) could kill hardware just like that. Just my opinion, of course.

Still no go with the TWRP boot.
I opened a ticket with Fairphone and explained the situation. I hope things will work out in that direction.

Thank you very much for your quick help and resourcefulness!