Mipad 4 building

OK, here we go:

  1. My last try.
  2. my roomserver.xml
  3. my buildscript

The device tree I have forked and removed the ipa make, because it defined in qcom folder. And I have changed all treble related lines to commend

(new zip will be available in 10 minutes)

1 Like

So I’ve been using the official twrp from the twrp.me site. With this version I encountered treble errors.

However I’ve since used the Mokee twrp and I do not get treble errors. So I will stick with that


I’m now going to try some of your previous builds with this twrp, and see how I get on. The 1404 most recent build doesn’t boot after bouncing e logo and reboots to twrp.

try last one which i’m just uploading

@harvey186 still the treble errors … i’m on official TWRP
@eggzenbeanz did you get it to work yet?

@harvey186 Maybe, do you think, the firmware must be updated? I’m gonna try it now

I did with the TWRP linked in previous comment. Build doesn’t boot, but I get no treble errors with that TWRP

what I don’t understand is, that the sources are designed for treble. Has someone checked if the device supports treble, for example with TrebleChecker app ? If yes, there is a new eOS-GSI available which should than also work on your device.
I would prefer, that you check treble or xda or something else how to enable treble on the Pad4 and using the GSI

Here it is written about LOS16 GSI for Clover. So you should go this way with the eOS GSI instead of LOS16

I found this video of a guy who solved the treble thing issue, so I tried it out on the 20200415 file… it sure did remove the treble errors! However, it only showed the bootlogo and returned to twrp. I’m running the latest version ( and formatted all partitions before flash. Sad.

@harvey186 I’m downloading the GSI now, hope to try!!
More info on Treble for the MiPad4: https://github.com/phhusson/treble_experimentations/wiki/Xiaomi-Mi-Pad-4

Good luck …

Gsi boots into fastboot for me. Either install via twrp system image or fastboot system flash

have you checked you device for treble support as I have written before ??

Treble is supported but a partition only. I downloaded a/b. Downloading A gsi now

Ok, what’s happens? The right GSI version fails also? ?

Yes that fails too - Flashes fine but reboots to back lit black screen :frowning:

Mhm, bad. sorry, so for me is this case closed, because I can’t see a way to ehlp further. Sorry :frowning:

1 Like

Thanks for all your hard work, very much appreciated

@harvey186 thank you so much for the good effort!

OK, last 3 days I have tried to flash eGSI on my new Mi Max 3 nitrogen. And … it’s running. I think I found some point which you can also try.

  1. Treble Info has shown that I do have an arm64 a/b device. But I have to flash the a_only GSI !!!

  2. And after flashing the GSI I have to change to vbmeta.img. You will find the image here
    thanks to Phh for this tip and command

  3. Download e-pie-20200416-UNOFFICIAL-treble_arm64_aeN.img.zip

  4. extract this zip. It will generate a 2GB img file

  5. download vbmeta.img

  6. boot your device in recovery and FORMAT data

  7. boot your device in fastboot mode (bootloader)

  8. run theses commands in terminal
    a) fastboot erase system
    b) fastboot flash system e-pie-20200416-UNOFFICIAL-treble_arm64_aeN.img
    c) fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
    d) fastboot reboot

and now your system show boot into eOS … i hope

my terminal log you will find here for comparing.

Good luck

Wow! That sounds promising. I’m downloading now, thanks!

Boots to a black screen again for me :frowning:

I can’t boot into the installed recovery too, I have to fastboot boot twrp.img then flash twrp again to gain recovery

but you have had it’s once booted in bouncing E, or not ? Try that version again, but with vbmeta flashing behind.