MMS never appear if mobile data are activated *after* the reception (FP3+)

FRANÇAIS PLUS BAS / FRENCH BELOW

Hi there.

I saw several topics regarding MMS and mobile data issues, like https://community.e.foundation/t/mms-without-mobile-data/5551/3.
Well, if having to manually activate mobile data to send or retrieve MMS is now more or less the norm (even on some “normal” Android devices), I guess I’ll bite the bullet and live with it (even if I find it really strange, given that my previous phone, running Android 2, was able to handle that transparently).

What does bother me, now, is that this happens:

  1. Someone sends me an MMS.
  2. I get a notification like: “Incoming MMS. Tap to allow MMS messaging for Orange.”
  3. I tap. This brings me to the settings for the Orange network.
  4. I manually turn on mobile data there, and open my room’s window to make sure I get some 4G.
  5. The “incoming MMS” never appears. I can’t even know who sent it. The same thing happens even if I activate mobile data really fast, as soon as I get the notification.

This does not seems to be mentioned in any community topic nor in GitLab tickets, as far as I know.

I did a test with mobile data activated before the MMS gets sent, and I get it just right.

This is a brand new Fairphone 3+ with preinstalled /e/OS. I updated the OS this morning just in case (10th of November build), and I switched to QKSMS, but the issue seems to run deeper than that. Also note that my APN settings seem fine (lots of Orange stuff automatically added, and anyway I can exchange MMS just fine with data activated). The SIM card is brand new as well.

Since Fairphone now has an official partnership with /e/, I hope something will be done to improve things at least a little bit. Not gonna lie, going from Android 2 to 10 and spending 500€ to finally run into weird issues like these leaves a bad aftertaste in my mouth. o( u_u )o

Thanks for reading.

TL; DR: MMS OK if data pre-activated, but never retrieved if data activated after the MMS was sent, despite a notification. No way to know who the sender is.

——— FRENCH ———

Bonjour,

J’ai vu qu’il existait déjà des sujets sur les MMS et les données mobiles, tels que https://community.e.foundation/t/mms-without-mobile-data/5551/3.
Si je dois activer manuellement les données pour envoyer ou recevoir des MMS, soit. Ça semble être « normal » sur certains téléphones, y compris avec des Android « classiques ». (Je suis étonné car l’activation temporaire était automatique sur mon Android 2, mais bon.)

Ce qui me gêne et n’a pas, à ma connaissance, été mentionné dans les sujets existants ou dans les tickets GitLab est ceci :

  1. On m’envoie un MMS.
  2. Je vois une notification du type « Incoming MMS. Tap to allow MMS messaging for Orange. »
  3. J’appuie sur la notification. Cela m’emmène aux paramètres du réseau Orange.
  4. Là, j’active manuellement les données, et je me mets à ma fenêtre pour avoir de la 4G.
  5. Le MMS n’apparaît jamais. De plus, impossible de savoir qui a tenté de me l’envoyer. Pas pratique pour le redemander à la personne concernée, donc.

J’ai testé en activant les données avant l’envoi du MMS, et je le reçois bien.
J’ai aussi testé en les activant non avant mais, disons, aussi vite que possible quand la notification apparaît, mais cela ne permet pas au MMS d’arriver.

Mon appareil est un Fairphone 3+ neuf avec /e/OS préinstallé. J’ai mis l’OS à jour ce matin avant ces derniers tests. C’est le build du 10 novembre. Je suis aussi passé sur QKSMS au cas où. Mes APN ont l’air bons (pleins de trucs Orange ajoutés automatiquement, et en tout cas avec les données je peux échanger des MMS). La SIM est neuve.

Puisque Fairphone a maintenant une sorte de partenariat avec /e/, j’espère que quelque chose sera fait pour que la situation s’améliore au moins un peu. Je ne voudrais pas sonner comme un gros rageux, mais… passer d’Android 2 à 10 et débourser 500€ pour finalement rencontrer ce type de problèmes me laisse un arrière-goût bizarre. J’ai l’impression d’être moins joignable qu’il y a douze ans. o( u_u )o

Merci d’avoir lu.

TL; DR : MMS OK si données pré-activées, mais jamais récupérés si on les active après l’envoi, malgré une notification demandant de les activer. Pas moyen de savoir qui est l’expéditeur dans ces cas-là.

Bonjour,

merci de votre achat et désolée pour le problème que vous rencontrez.

  1. D’où vient cette notification ? De quelle application/service ? Avez-vous une capture d’écran s’il vous plaît ?

  2. Pourriez-vous faire le test avec une autre carte SIM ? D’un autre opérateur si possible.

  3. Vous pourriez également essayé de réinitialiser les différents paramètres de connexions :

  • Paramètres > Système > Options avancées > Options de réinitialisation > Réinitialiser le Wi-Fi, les données mobiles et le Bluetooth > RÉINITIALISER LES PARAMÈTRES.

Bien à vous.

Rough English summary: Check notif logs in screenshot.

Merci d’avoir répondu ^^

Oh, je viens de découvrir le log des notifications (comme je disais, je débarque d’Android 2, donc je suis parfois un peu à la ramasse). Ça va peut-être démystifier un peu tout ça.

La notification semble provenir des Settings eux-mêmes. Pas délirant, vu que c’est dans les paramètres, justement, que j’atterris si j’appuie dessus.

notif-log_edit

Plus rigolo : la fin du message, qui était tronquée et que je découvre donc via le log, semble dire qu’il est possible d’activer la gestion des MMS sans avoir à activer les données manuellement. Alors que je ne vois aucun paramètre explicitement dédié à cela et que j’ai lu partout dans le coin que ça n’était pas implémenté. Chelou.

C’est peut-être super trivial, je sais pas.
En tout cas dans les paramètres du réseau, là où la notification m’emmène, j’ai juste :

  • Mobile data (ce que j’active alors, mais sans effet particulier),
  • Roaming (semble hors-sujet),
  • App data usage,
  • 4G calling (toujours activé),
  • Preferred network type (4G),
  • Wi-Fi calling (Off),
  • Automatically select network (ouais),
  • un Choose network grisé avec Orange F dedans,
  • et enfin les APN.

Donc quand ça me téléporte ici, je suis un peu en mode « Euh ouais OK mais tu veux que je fasse quoi maintenant ? ». xD

À noter que je n’ai pas trop pigé comment était fichu le menu des APN. Il y a un bouton radio pour chaque point d’accès, et une fois qu’on en a choisi un, le seul moyen que j’ai trouvé pour tout désélectionner de nouveau est de réinitialiser tous les paramètres d’APN. Et les trucs d’Orange ajoutés automatiquement n’ont pas de bouton radio. C’est probablement tout à fait normal mais je n’ai jamais trop su quoi faire de tout ça. Dans le doute je n’ai rien touché.

Je verrai si je peux bidouiller avec la SIM d’un de mes parents (si c’est du nano) un de ces quatre, si jamais ce log n’aide pas. Ils risquent de ne pas être trop fans mais bon.

Merci.

Edit
(Can’t find the “Reply” button for some reason, maybe because I’m the author of the latest message. Or I just went blind in a day.)

My mom uses a different carrier, but has a not-trivially-cutable micro and the FP3+ wants a nano. And my dad uses Orange like me. The pandemic lockdown limits my options, and I don’t really feel like asking for a random neighbour’s SIM card, especially now that the same issue was raised by someone else: MMS reception issue on FP3/FP3+ (In France)

Googling (sorry, Duckduckgo) the notification’s text leads to stuff like: https://forum.xda-developers.com/showpost.php?s=3d2fd88b7f4a9f2fe160b31eddd23048&p=81993375&postcount=18
where people say:

If you go into settings, and then to “SIM cards & mobile networks”, is the “Always receive MMS” toggle in the on position (blue)?

I never saw that toggle. Sounds really fishy.

That’s because this topic has been moved in the French part of the forum and you have to “Join” this part in order to be able to interact with topics in it.

Let’s continue in English in the other topic in order to centralize things.

To temporary avoid this problem you can use another messaging app (it worked for me at least). Therefore it is a problem from the /e/ messaging app, I hope they will fix it soon.
Related bug on gitlab : https://gitlab.e.foundation/e/backlog/-/issues/2155#note_67390

Alors j’ai testé pas mal de trucs, et je crois avoir trouvé 2 solutions :

  • Si tu veux désactiver les données et recevoir des MMS (par exemple si tu as un forfait sans data), il faut modifier tes paramètres APN : dans la section “Type d’APN” tu mets juste “mms” et normalement ça marche

  • Si tu es avec les datas désactivés et un APN avec des “Type d’APN” supplémentaire (dans mon cas c’était “default,supl,mms”), dans ce cas je n’ai trouvé qu’une solution pour récupérer les mms après réactivation des datas. Tu peux télecharger l’appli de messages de google (dispo dans l’app store)… un peu ballot…

Voilà, en espérant avoir été clair, ce problème m’a pas mal cassé la tête :slight_smile:
Je veux bien avoir vos retour, pour savoir si ça vous à aidé

Merci pour l’exploration. Ça fait un peu flipper mais ça peut valoir le coup de tester. Les données risquent de rester, avec ce forfait, un truc d’urgence en cas de besoin d’une info à un endroit et moment pourri. Donc je suppose que je peux passer en « juste MMS » et, le cas échéant, réinitialiser ou whatever. C’est un peu dégueulasse (et ça sera un peu en mode « no idea what I’m doing »), mais bon, à voir un de ces quatre.

J’ai commenté sur l’autre fil ; le problème vient au moins partiellement de QKSMS, mais j’pige pas pourquoi ça marcherait sur certains téléphones. :woman_shrugging: