MMS reception issue on FP3/FP3+ (In France)

Hello :slight_smile:

I own a Fairphone 3 and a 3+, in whitch the rom /e/ (eelo) is installed.

I have a problem while recieving MMS messages : if the data connection is activated, it works. But if the data is desactivated, i have a notification like this :

Screenshot_20201122-210201_Bliss_Launcher2

Translation from French :
" Settings : MMS Incoming : Press here to allow the MMS with Orange F (the operator) while the mobile data is desactivated"
If i press the notification, i reach the mobile network settings (data connection, roaming, APN… )

The main problem is here : I have this notification when i recieve a MMS while the data is off, but if i switch on the data just after, i do not recive the MMS, so it is definetly lost. (And i cannot guess who send it and ask him to send it again when my data is activated…)

So for the moment, i have to keep always the data on to be sure that i miss any message :confused: (Sometimes, long text messages come by MMS)

In my old phone (a Honor 5X , also with /e/, it happened like this :

  • MMS reception without data -> Nothing happen
  • Switching on the data after -> The MMS is recieved

Is it possible to have the same running on my FP3 (and 3+) ?

Thanks a lot in advance. :smiley: :slight_smile: :slight_smile: :slight_smile:

Note : I am in France. The FP3 is on the operator “Free Mobile” and the FP3+ is on the operator “Orange”. The two of them have exactly the same issue.

I also created the discussion on the Fairphone forum to maximize the chances to find a solution. I am getting quite desperate ^^

Sounds really similar to my MMS never appear if mobile data are activated *after* the reception (FP3+).
Glad to see I’m not alone.
See my posts; there seems to be a missing togglable option in our settings or something. :woman_shrugging:

I really want to sing praises for /e/ and Fairphone, and each day I find new reasons to like my new phone, but as long as the holy triptych of SMS / MMS / calls is not stable, my friends will have reactions like “sounds like a chore” or “crap” (that’s basically what they are saying right now, seeing me struggle to fetch my MMSs, which worked just fine with my first, non-smart phone).

Good luck to the devs. Wish I could help but I mostly deal with non-mobile stuff. And Bash scripts (:heart:). xD

Tiens, un HL / DF boy :wink:

Are all APN settings OK ?
See www for Orange’s APN and check
Settings > Mobile network > More > Mobile network > Access names

Good luck.

Pretty sure that’s not an APN issue since my SIM automatically added stuff that matches what’s in https://assistance.orange.fr/mobile-tablette/tous-les-mobiles-et-tablettes/depanner/probleme-avec-un-service-d-orange-internet-sms-mms-mails-cloud-tv/mms/configurer-un-apn-internet-et-mms_192948-738196#onglet2. Never had to fiddle with APN settings with Orange in like twelve years, too.

@alice_m : glad to see that i am not alone too ^^
Yes, that looks the same problem than me. So, what can we do ? :confused: Report the issue to the devs and hope a patch update ? :confused:

@trefix : Coucou cher ami HL / DF :slight_smile:
The APN settings seems correct because the reception work when the data connection is activated.

I don’t see anything really better.

Are those posts enough? I’m new here; I dunno if they tend to create tickets according to what we write, etc. I don’t even understand if “Anonymous” is a single user with “Anonymous” hard-written as their name, or an umbrella profile used by the whole /e/ team. xD

I’m not in a hurry or anything to get a fix, but at least seeing that core features like this are taken seriously would put me at ease. Especially with Fairphones. I doubt the FP team will be happy if their nice-looking partnership with /e/ ends up as a train wreck for nearly all French users. Can’t be good for anyone.

Hello,

Is your FP3 on Pie or on Android 10 ? If it’s on Android 10, do you know if the issue also occurred on Pie ?

Could you both make sure you are on the latest version of /e/OS and share which version it is please ? Should be something like “0.12-20201110xxxx”.

  • Everything is in Settings > System > Advanced > Updater, click the curved arrow at top right to see the latest version and install it.

I’m a single member of the support and after-sales team who chose the name “Anonyme”.

I just opened an issue in our gitlab and shared it with the dev team. You can follow the progress :

1 Like

Thanks a bunch for the answers and the ticket.

As stated in my original post yesterday:

I updated the OS this morning just in case (10th of November build)

so it matches the version you’re referring to.

0.12-2020111084009
1 Like

Feel free to use my https://community.e.foundation/uploads/default/original/2X/3/3164f5645f881108327e7fc29e48c33385e4216b.png from yesterday if you need something for the “Relevant screenshots” section of the ticket.

1 Like

Thanks for your answer and the ticket !

My FP3 /e/ version is 0.12-2020111084008
Its Operator is Free Mobile
One more detail : I have two SIM cards of this same operator in it (professionnal and personnal separate numbers). The second one is used by default for the data connection. So, the first one never have data connection, and consequently never can recieve or send MMS.

The FP3+ /e/ version is also 0.12-2020111084008.
This one have only one SIM Card. Its operator is Sosh (Orange)

It seems the priority was decreased from 1 to 3. Judging from the size of the backlog (I’m not blaming; backlogs are known to be huge in virtually every project in the world), I doubt we’ll see a fix anytime soon.

Honestly, I’m not a fan of the reasons that were given:

I doubt MMS is a widely used technology outside of France

  • Many phones automatically convert long (>10) SMSs into MMSs when sending them. Such messages will never be received with this bug. This conversion option is even available in the default messaging application of /e/.

  • I’m not sure why the habits of French people would differ significantly from what can be found anywhere else.

  • The main reason MMS has seen a drop in use in my opinion is because people send pictures via WhatsApp. But I didn’t buy a Fairphone with /e/ to start installing creepy GAFAM stuff and creating weird accounts on the corresponding services.

leaving data always on is pretty much the norm IMHO

  • Every carrier seems to have a low cost option, and in the case of, for example, Free, their 2 € subscription was even at a time their main way of making people talk about them. My mother is still using that subscription.
    I have 100 MB and a poor reception most of the time. Keeping mobile data on would only be a waste of power, and if I start, for example, listening to a web radio while forgetting to enable Wi-Fi, my 100 MB will be doomed (this might be tweaked via settings to forbid the browser from using data at all, but not sure).

Of course I’m no statistician or anything and can only vouch for the few cases I know about, but still, the declarations quoted above seem a bit hasty to me. Especially if this bug was reproduced even with non-French carriers (making its scope way bigger than initially supposed).

1 Like

I commented the issue: https://gitlab.e.foundation/e/backlog/-/issues/2155#note_67390

I tried to convince that this problem has a non-insignificant impact.

In my case I use FP3+ with Bouygues-Telecom and the APN settings automatically added from my SIM were wrong, so I couldn’t connect on the internet via mobile data. I took time to set the APN manually and now everything is working just fine.
It could be the same in your case.

Thanks. It seems that the ticket already fell into limbo, though. Even the build numbers you reported were not written in it (still “waiting for input”). :cry:

Thanks for taking the time to write this, but I highly doubt I’m in the same case, or at least not exactly. Activating mobile data before trying to send an MMS or receiving one or loading any web-based thing works fine in my case (which is kinda why the ticket’s priority got nuked). I also checked most (if not all) fields and it really seemed to match the official Orange recommendations.

I have tried on my phone, I have the same issue : the MMS are not “stored” to be accessible after enabling the data.
I tried the same thing with another message app from the app store and it is working (as you can see on the following picture)
So it is a problem from the default message app from /e/ !!
IMG_20201128_121848

Your “that I won’t name” on the ticket is scary xD I suppose it’s a tracker-ridden app most /e/ users won’t feel like using?

I’ve been using the unforked version of QKSMS since my initial investigations (it supports the dark theme better, while the /e/ version displayed stuff in white on grey speech bubbles, so I kept it :sweat_smile:), and it has the issue too.

By browsing their (QKSMS) issues, I found this:


It’s old as hell. :scream:
There’s a…

this is definitely one of the most important things I plan to work on in the near future

… though. But even that particular comment is months old already.

But wait… Then how can it work on other phone models? :exploding_head:

Something doesn’t add up. :neutral_face: Did old /e/ use another default messaging application?

Yes I did tried QKSMS and the issue is coming from this app…
The app message which is working is the google one. And fun fact, when I installed it I get access to all the MMS I did not received before. Therefore, the mms are somewhere and I don’t understand why it is not possible to get the on QKSMS or e app. (But the great thing is that your MMS are not lost… If you are ready to use google message).

And I have to add one thing : when I went back to /e/ message app after that, it has downloaded some MMS sometimes, but not all of them…

I do not understand a thing…

Hello, I had the same problem when I switched To the fairphone, aT first with the stock android, and she with e (with either the messaging app and Silence).
Finally I discovered that the APN infos weren’t matchimg exactly what my operator (SFR).recommends. So I changed the settings from a nearly good config (could also.have created one) and rince then hade noproblem to receive mms at the moment I turn mobile data on.
Note : the APN settings become adailable to choose, ie the radio button appears, when I put the correct APN Type, not sure if it is the “default” keyword that made the trick.
Caveat : SFR loesn’t seems so understand.that some people may not have data pirmanently, so keeps sending messages offering me to.download the mms from a.website … So I believe it’s not that simple nowadays to have a phone without data enabled all the time.
Btw : try with another sms reader than qksms, I have tried it before and had so drop it because.of mms issues. Otherwise I loved all the rest of it.

1 Like

Hello,
I’ve a similar problem (well, worse) : I’m in France and I can’t send nor recieve any mms, even when my data connection was already activated.
I checked the settings (APN…) and they were the same as what my mobile operator said they should be,.

My FP3+ has the latest version of /e/OS. My mobile operator is Bouygue.

Has anyone found a solution since ?

Hello. There seems to be a lot of threads on this but I don’t see any that have a solution. I just want to add that I just realized I have the same issue, and I do not live in France. Besides, even if it were just an issue that French people have, I don’t see why it shouldn’t still be taken seriously…

I am going to repeat what was sent multiple times before, but I was sent an MMS and I had no idea this bug was a reoccurring issue. The MMS does not show up, and I did have my mobile data turned off, but the Wi-fi was on. I cannot see the MMS at all now. If the MMS is indeed stored somewhere such that the Google messaging app has access to it, I find it very strange that the original /e/ messaging app cannot see it. And no, obviously I do not want to turn on mobile data 100% of the time, it’s does not serve any purpose and it is money consuming.

Does anyone have more precise steps to follow regarding APN settings? I am quite confused by them. Alternatively, if anyone knows of a non-Google app for SMS and MMS that works, I’m all ears.