'Mobile network' menu not accessible and SIM NOT Detected

Hello, I have a Motorola Moto E LTE, Model: XT1527 Moto E 4G LTE (2015) and the ‘Mobile network’ menu in Settings–>Network and internet is not accessible. Nothing happens when I tap on it.

I’ve tried putting an active SIM card in the device but it doesn’t detect it. On the lock screen it says “No SIM card - Emergency calls only”. It also doesn’t prompt for an unlock code when I put my active SIM card in.

Has anyone else encountered this issue on the XT1527 Moto E 4G LTE (2015) or any other device with e/os for that matter? Thanks!

Hi @_rusteh welcome to the /e/ forum.

Please could you clarify has this or another SIM been tested on this /e/ install ? Was a SIM installed when the First start wizard was run (where Region, Language, Time & date are set straight after /e/ is installed) ?

Your case reminds me of this

In the first instance I would check out the references in the above case to Access Point Names #apn ← is a hashtag to other threads on the subject.

  • There are other cases revealed by this link to a search of the forum SIM not detected.

Thank you sincerely for the reply. I was trying to search the forum but didn’t know where to start.

I’m in Canada and the active SIM card I have is Virgin Plus (Mobile). I’ve tested the SIM in an iPhone so I know it’s active. I haven’t tried my /e/ install with another SIM. The other confounding factor is the XT1527 Moto E 4G LTE (2015) may be locked to Rogers but I don’t know how to find that out.

I didn’t have a SIM card installed when I initially flashed /e/ on the XT1527 Moto E 4G LTE (2015). However, I tried a ‘Factory Reset’ from the /e/ recovery partition after I got the Virgin SIM card and that didn’t work.

The other issue is that I can’t access the ‘Mobile network’ menu. It shows up in Settings–>Network and internet but when I tap it nothing happens.

Also, on the ‘lock’ screen it displays at the top of the screen “No SIM card - Emergency calls only”

The version of /e/ I have on the XT1527 Moto E 4G LTE (2015) is:
Andriod 10
April 16, 2023

The Build number is:
e_surnia-user 10 QQ3A.200805.001

Searching online “Canada Rogers locked” suggests that there several firms which will take money to unlock a device ! In Europe carriers are expected to release their devices if fully paid up and out of contract.

On this page https://canadaunlocking.com/unlock-rogers-phone I read

Free Fido & Rogers and Chatr Unlocking (Rogers-Fido-Chatr)
In many cases it is possible to obtain an unlock code or an iPhone unlocking service for your Rogers device free of charge by calling Rogers customer support directly by calling Toll Free 1 (888) 764-3771 however, if you are on a corporate plan or your account is not in good standing they may refuse to unlock it. For corporate accounts, Rogers is still charging an unlocking fee as of 2020. It is possible to Unlock Rogers iphone free using this method however the latest news about Rogers unlocking states that you will need to be a Rogers customer still or have left within the last year and with no outstanding fees,to do so. According to the Rogers unlock policy these conditions have not been mentioned.

I guess you would want to rule out carrier locking as your symptoms seem consistent with this.

Roger that. Could the carrier lock also be the reason that I can’t enter the ‘Mobile network’ in /e/?

I think it all fits but I cannot tell the certainty of this view.

Were you yourself a Rogers customer, what is it that makes you think Rogers are / might be involved ?

Did you use this phone with a SIM before /e/ install ?

Say you were to contact Virgin with a view to asking them to send the APN to the phone. If Virgin is providing the Emergency Call service then they should be able to “see” the device and send the APN. If however they cannot detect their own SIM online, it would suggest some “missing link”, I think.

If you use the Search facility in Settings, do you find APN ?

It’s a phone that I have for work that was under the Government contract when Rogers had the contract. Rogers was still locking their phones in 2015/2016 before the Federal Government changed the rules. The device was previously working with a Rogers SIM card when it was last used in 2016 or 2017.

I never actually saw a carrier locked device in action; in most of the “SIM not detected” and apn threads on the forum the /e/user can at least navigate to:

Settings > Network and internet > Mobile network > Advanced > Access point names > tap + for “add APN” at top of screen.

While in your case I think you simply hit a dead end at

Settings > Network and internet > Mobile network

So on reflection and with the history you describe I feel there is a good chance that dead end = carrier SIM locked.

I suggest you collect the IMEI from the device (various methods, first look at Settings > About phone) before you try to speak to Rogers customer support, maybe they will plead “Corporate customer” confidentiality … but the existence of your IMEI on their database of unreleased devices would likely confirm carrier SIM locked.

A “sideways” approach to Rogers customer support would be to see if they will provide a new SIM and plan for the device, perhaps ?