Moto G 2015 - "osprey" - Build?

Hi /e/s, nice to meet, this is my first post.
I am trying to /e/ an old Moto G 2015, which has a “community” level ROM.
Acc. to it’s page, the work consists of download, install, and build.
I got as far as the bottom of install:
---- 9. Once installation has finished, return to the main menu, tap Reboot, and then System.
Actually, I expected that the at that point the /e/-OS would start, but no, there comes this page “build”, which looks very intimidating to an amateur like me. Do I really have to do all that? On a Ubuntu machine? It seems there is no relation with the actions of “install” at all: I thought I had already put the OS on the phone.
Can someone please explain the context of what happens here, I am lost.

Hi @sugit , you are right the section Build and Install are different. There is no connection between the two. If you are ooking to install /e/ on you phone you only need to follow what is there in the ‘install’ section. The details in the ‘Build’ section is for those who want to build the ROM themselves.
We will update the wording in the wiki so that it does not confuse users.

1 Like

The build section isn’t necessery in order to install /e/.
Are you sure you have correctly installed /e/ ? You should try again if not :slight_smile:

1 Like

OK, thanks guys, so that is cleared up.
So, at the bottom of install, I tap Reboot, and then System. Now TWRP says “Swipe to Install TWRP App?” . Here I clicked on “Do not install”, because obviously TWRP is already installed.
Then I get the (usual) message from Motorola: “Warning Bootloader unlocked”. The only way to get out of that message (which came many times before during the process) is to hold <vol.down + power> for 15 seconds. Then I get back to Recovery mode.
There I have the options (as usual) Start / Restart Bootloader / Recovery Mode (–> TWRP) / Factory Mode / Barcodes / BP tools / Qcom / Bootloader Logs / Switch Tools Mode
So apparently no automatic start of the OS. Anyone knows what to do here?
Or maybe should I install “TWRP App” ?

I don’t think install TWRP app will change anything because I suppose it’s just an app like others.
I’m an expert in flashing Samsung phone but that’s all so you will have to wait for another person sorry :wink:

Thanks @Anonyme.
I think mayby that “TWRP App” means the OS-build that was uploade to the phone, but I will wait for someone to confirm.

Don’t bother with TWRP App, it doesn’t change anything. I didn’t install it and my Samsung phone works very well.

1 Like

OK, so that would not work. That leaves the question: what now?
After Reboot and System, what is supposed to happen? Do I need to choose one of the options of the Reboot mode (mentioned above) ?
How do I get “” to unpack to /e/-OS ?

I don’t know exactly where you are in the process because I don’t know your phone but you can try to follow the steps AFTER “7) Install /e/ with TWRP”.
It might not help but that’s all I can do for you :confused:

1 Like

If you have got TWRP installed, which seems to be the case for you, you can easily install /e/ once you have got the file on your device - where xxxx is the date and number of the revision. You get it from here for the “osprey”. Choose the most recent one at the top of the list.
To get this zip file on the Moto, you can either sideload it as described in the last part of the “install” page Installing /e/ from custom recovery or you can copy it onto a spare sd-card from your computer and insert this into the Moto. In both cases you end up with the essential file on your mobile which is where TWRP can find it.
Now all you need to do is boot into revovery which you can do manually in the device by holding down the volume down button and the power button simultaneously as described on this page. Then you press the volume down button twice to choose Recovery then confirm your choise by pressing the power button. This will get you into TWRP.
At this point you can perform a backup as described on the Lineage page (there’s a link from the /e/ install page indicated above. This is mainly for peace of mind because it allows you to reinstall the system as it was if /e/ is not to your liking. Surely not! Then you can do the clean install method which is to wipe your data. With the “wipe” button, then choose Dalvik Cache, System, Data & cache to wipe everything clean. After this go back to the start screen and choose “Install”. Here you will probably have to find the “” file which should be at the bottom of the list of directories assuming your sideload put it there or if it’s on the second sdcard you have to navigate there to find your file.
Once chosen, you simply launch the installation by swiping to the right. Wait until it says the installation was okay. and then choose “Reboot Sysytem”.
You have wait a while (a couple of minutes in general) for the /e/ system to start bacause it has to reindex the cache files but the following reboots are much shorter.
If you’re not bothered about making a backup, you can simply do what’s called a “dirty flash” which means you just reinstall on top of your exisiting system. This usually works but you have no backup of course. For the updates “dirty flashing” is the usual method. However, if your Moto G is like mine - I have the ‘peregrine’ version - then the updates are handled automatically and you don’t have to touch TWRP again.
Hope this helps.

1 Like

Thanks for all the input.
I managed to do most of it. Problems develop with sideload, that stops at “47%” and the PC says “error”. (On the phone it seems to have worked, but the .zip is nowhere to be found.)
Then tried simply a file copy via my the PCs Explorer. That was a bit unclear, but at least the file could be found. Tried to Install that. That seemed to work, but after Reboot System the phone shows the motorola screen “Warning Bootloader Unlocked”. So maybe the .zip was not copied correctly. put the .zip file on a SDcard, then went back to Recovery mode and now copied from the SDcard to the internal file system, tried Install again.
Same story: seems to have worked:

But when I click Reboot System, then the Motorola warning comes up again:

I left this running for more than 60 minutes (maybe /e/ takes a lot of time rebooting?), but nothing changes, just the warning.

Does that Motorola warning maybe mean that I have not wiped the old OS good enough? I did wipe it already 4 times, as described in the instructions, and also as @Grendel says: Dalvik Cache, System, Data and cache.
Or some other part of the Moto OS has remained in place? When, from Recovery, I choose Start, then I first get a Motorola start screen for 10 seconds, then again the Warning Bootloader Unlocked.

So stuck on the final step it seems. Any advice very welcome.

I’m afraid I had no such problem with my Moto G peregrine. It looks like the stock boot image file is not working for some reason. Are you sure that you flashed the correct TWRP? I found that I had to rename their file to simply twrp.img without the intervening version details. It then flashed TWRP correctly.
If it is a more serious corrupted boot.img I think the only solution is to go back to the factory firmware and start again. This page seems to give a good relatively simple way to go back to stock and you could try leaving the bootloader unlocked in the last steps to be able to flash TWRP again and install /e/ as before.
I can’t vouch for this solution as I have never had to try it, but other sections on the xda-developers site mention getting stuck at the unlocked bootloader warning page. They also have a detailed section on factory resetting.

1 Like

Thanks a lot Grendel.
Thing is, as TWRP I used twrp-3.3.0-0-osprey.img. That seems really the correct file, and it seems to work correct up until the last step. I would not have another option, or do you advise to try an older version ?

To see if there is a problem with the boot.img file on the /e/ zipfile you could first of all try installing the original Lineage OS 14.1 which is built on the same nougat 7.1 android version as /e/ uses I believe - at least this is the case with the peregrine model I installed it on. This is nearly 4 years old and doesn’t have the security updates but at least it would be a test to see if this older boot.img works.
As for an older twrp recovery, I think it more likely that a more recent version might have a fix for any incorrect flashing problem. I’m not an expert on this though.

1 Like

A quick further suggestion to simplify testing as I noticed this on the troubleshooting section of the xda-developers site:

A word of advice: I strongly recommend temporarily booting any images (be it recoveries or kernels) you are about to flash to your device. This is simply a case of using the command “fastboot boot blahblah.img” whether blahblah.img is a recovery or kernel


1 Like

@Grendel: Sorry, what is “temporarily booting” an image? I only understand what it says in the “recipe” to add the TWRP and the ROM, but do not have the conceptual understanding for this apparently.

As I understand his “word of advice” you should connect your moto to your computer to use adb through a command window assuming you use Windows and then you put the decompressed zip file of the ROM to test in the same directory (probably C:\adb if that’s where you’ve got it) then give the command:
fastboot boot boot.img
Remember to check that fastboot does connect to your device with “fastboot devices” beforehand and that you are in fastboot mode.

1 Like

On my PC I have unpacked <> in the same directory as fastboot.exe.
Running fastboot devices works.
Then running fastboot boot boot.img says:

Now the MotoG3 goes out of fastboot-mode and gives the usual Moto warning: “Warning Bootloader unlocked”. Nothing else happens.

I did a search on the internet, and it seems the phone is soft-bricked… The message seems to be “normal”, but the fact that the phone is not booting is not normal. Unfortunately i don’t know how to do that on this device.

Did you try the old Lineage OS v. 14.1? If this works, then it is a problem with the /e/ zipfile. Have you got the original single-sim version or the dual one. I think they are quite different. Again the help FAQ on the xda-developers site has information on this.
There is a link also to a special version of TWRP by squid2 which from the comments on the site seemed to have worked with many variants of the “osprey” MotoG. You could try flashing this as a new recovery and then installing /e/ afterwards.