Moto G4 Play echo problem? (XMPP calls)

I’ve installed /e/OS0.7-2019112732147 on two G4 Play phones in order to do video calls via XMPP. Using aTalk I’m hearing an echo at the calling end. Receiving end sometimes ok sometimes also hears echo. Tried all combinations of Echo Cancellation and noise reduction settings in aTalk.

This is annoying and also makes it impossible to put it on speaker due to feedback (squeal).

Issue may be just with using aTalk but the latter seems a very well maintained app that should work as intended. Anyone else tried this? Thanks

Hi, yes this issue is already reported, you can found details here :

But looks like there is no solution for now…

Thanks - mine occurs also without putting it on speaker.

Without speaker ? That’s weird. And even with the volume call at minium ?
Because if microphones can’t hear what comes out, echo can’t exist.

Maybe the standard echo cancellation doesn’t work. The receiving end gets the signal and reflects it back to the caller. Putting it on speaker makes it worse (squeal).

aTalk seems to be able to cancel one side of the echo.

It could be a different issue if it doesn’t involve the speaker.

Could you raise an issue in the gitlab with as most details as possible please ? It’s the best thing to do to have an issue solved.

Thank you :slight_smile:

sorry Anonyme I initially thought this concerns ordinary voice calls as well but it happens using XMPP.

Also happens with a Moto E2 on one end, so maybe not related to G4 Play specifically

Update: tested the latest version of aTalk (2.1.5) on G4 Play running standard Android 7 and there was no audio echo problem. Then trying e-0.7-n-2019122535327 with the same version of aTalk, the echo is there, leading to squeal in speaker mode.

Have you already tested LineageOS-14.1-for-microG for Moto G4 Play “harpia”? If the same echo problem occurs, then in LOS 14.1 the reason is probably a bug?