Moto G5 - Installation issue


I have an issue during the installation of /e/OS on a Moto G5 Cedric.
I can install the recovery ant begin to install the OS.
But, at the end, I have this message :
“ERROR ; This package requires formware from an Android 8.1 based stock ROM build. Please upgrade firmware and retry !
E:Error in /sideload/ (status 1)”.

I am sure that my version of Android is 8.1.0 (I was sure at the first time, but I checked and retried : I am on 8.1.0). So I don’t understand the issue…

Thank you for your help !


Edit : logically, I had the same issue with Lineage OS 18.1.

Finally, I succeeded ! An update was possible but not in the Android system of the phone.
My version was : Android 8.1.0 - OPPS28.85-13-6.
And It’s possible to install a newer version with TWRP : “adb loadside”.

1 Like

Could you please point me to source of newer Android image you mention? I got the same error while flashing /e/, that’s how I found the thread; I’ve tried “” from androidfilehost, but with that file adb sideload fails almost immediately with “E:footer is wrong”.

My G5 also was already on 8.1, I have checked…

OK, seems I have managed to install /e/, so I’ll write down how, for others (and for my own memory, should I ever need to install it again). Just a reminder, that I’m not privy to how the system works and I was merely glueing together informations I’ve found. Also, I just hope that third-party site I got the needed file from did not modify it in any way, but I have no way to confirm it, other than it seems recognized on xda-developers.

Some steps were maybe not needed, but this is how I did it.

Following offcial instructions I encountered the same error as Mat35:

ERROR: This package requires firmware from an Android 8.1 based stock ROM build. Please upgrade firmware and retry!
E:Error in /sideload/ (status 1)

My phone was on 8.1 and there was no OTA available. Following Mat35’s suggestion I’ve tried flashing “”, but the file I’ve found (on androidfilehost) was unflashable, adb sideload was immediately throwing an error.

On xda-developers I’ve found a suggestion to flash only modem firmware, taken from original Motorola ROM. I’ve found such ROM, matching my specific device (XT1676, RETEU — many posts suggest RETAIL, I suppose RETEU is for European version, and as the regulations concerning radios are different across the world, I wanted to have EU version) on . In my case, it was (the RETEU version is further down the page, not the first one. Check the filename).

From the downloaded .zip i extracted file Firmware/NON-HLOS.bin (md5 is 3605a87a6e4ba36c2f995204a7ec2aa6)

I rebooted into bootloader (adb reboot bootloader), issued command fastboot flash modem NON-HLOS.bin, then rebooted (still into the original system) to check that I can still access the mobile network and data. I could.

Then I followed the original instructions, with the additional step, that in “Installing a custom recovery using fastboot” section, just before flashing recovery, I did fastboot flash modem NON-HLOS.bin (yes, again, probably not needed), then proceeded to fastboot flash recovery ... and followed the instruction without further modifications.

Everything works, just one thing seems different: on stock ROM, I had “LTE+” mark, now it’s just “LTE”. I don’t know what the actual difference is; mobile data and calls work, and I have not tested speeds before, so I have nothing to compare against now.

I hope it would be helpful to someone who encouters the same strange error of ”updating 8.1 to 8.1”.

1 Like