Moto G7 Power unlocking problem

I’m trying to instell /E/ os on a Moto G7 Power, but I don’t get very far. I already spent a couple of hours to unlock the device. following the documentation to enable USB debugging and unlocking the device( Enable USB Debugging and OEM Unlock), I tried to set the oem unlock setting, but it was grayed out. After several hours of trying and researching, I found out, that this setting can only be changed if you have an simcard in your device and I didn’t :frowning:

So I put in a sim card an now I have become a develloper by taping the buildnumber 7 times, I allowed debugging and I’ve set the oem unlock option to enable. I installied ADB and fastboot on my windows 10 pc.

So I connect my device to the pc and open a commandline window. Then I check if the device is connected by typing adb devices and the device is listed as ZY323 ect. but behind the devicenumber it says “unauthorized”.
Next I follow the documentation and type "adb fastboot devices. The I get the following:

“C:\Platformtools\platform-tools>adb reboot bootloader
error: device unauthorized.
This adb server’s $ADB_VENDOR_KEYS is not set
Try ‘adb kill-server’ if that seems wrong.
Otherwise check for a confirmation dialog on your device.”

So I tried typing “adb kill-server”, but that didn’t help.

Then I looked for messages on the device and I got a message asking if debugging should be allowed, which I did.

Then I retyped "adb reboot bootloader"and the device went into bootloader mode.
Happy at first, but…
Now I checked if the device was connected and recognized, so I typed "ADB devices: no devices are found although on my phone the last 2 lines say “OEM locked” and “transfer mode: USB connected” If I disconnect the USB cable, the last line changes to : “connect a USB data cable” and when I reconnect it changes back to “Transfer Mode: USB connected”. So the cable is obviously ok.

When I try to get my device ID to be able to unlock the device and type: “fastboot oem get_unlock_data”, it returns: "waiting for any device "
And that’s all. I have to close the command prompt window and restart the phone to be able to use it again.
So I can’t get the Device ID that I need to get an unlocking code from Motorola. A that means I can’t install /e/ os :frowning: .

I would really appreciate it if anyone could help me out.

Have you checked after restarting the stock os if the usb debugging did not turn off itself in the background?

Yes, it is still in debugging mode.
I tried to find answers by googling and came up with a possible cause. Maybe the latest usb drivers were not installed. I found this site: Fastboot Not Detecting Device on Windows 10/ 11? Here's the Fix | Beebom
and I downloaded the file android_winusb.inf. Supposedly that is the driver to correctly find the device in fastbootmode as I understand it. But if I try to install it with device manager, I can see the device under "other devices as Fastboot ocean S. When I rightclick on it and select “properties”, it says that there is no driver installed for this device (code 28). When I click on “update drivers” no drivers can be found.
I don’t know what to do next.

okay, installing adb and fastboot on the computer makes sense :sweat_smile:
with Windows itself I cannot help you too much, as I am a linux user from years :angel:
however for /e/ I am trying to use Moto G7 Power as well, I had Lineage OS earlier on it :wink:

Did you get a dialogue on your phone when you connect it by usb? It should ask if your pc is to be allowed to do adb debugging.

After this dialogue is confirmed you should get an authorized device (the command “adb devices” lists your phone)

Regarding Windows drivers it is worth. leaving the install instructions on one side for a bit.

Now check for :warning: Problem device
in normally booted mode.

Again repeat in Recovery mode where adb will happen.

Any sign of :warning: Windows Update at each stage.

Again repeat in Fastboot mode.

If necessary be prepared to go round in circles like this for a few cycles.

No, I did not get a dialogue on my phone to allow my pc to do adb debugging.
When I use the command adb devices before rebooting to fastboot, I see my phone with behind it “unauthorized”, after rebooting to fastboot the device is no longer visible, so I think you’ve probably nailed the problem. But then the question is how do I authorize the PC? :wink:


When the device is not in fastboot mode, there is no problem sign. When in fastboot mode there is and when I right click on it, I find these messages:

Device settings for USB\VID_22B8&PID_2E80\ZY323VPCJL were not migrated from previous OS installation due to partial or ambiguous device match.

Last Device Instance Id: USB\VID_05DC&PID_A81D\AA0AFU7UBMHSHZ8S
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Location Path: PCIROOT(0)#PCI(0801)#PCI(0003)#USBROOT(0)#USB(2)
Migration Rank: 0xF000FFFFFFFF0023
Present: false
Status: 0xC0000719

I havent got a clue what it means, but maybe you can make sense of it?

The first link I read from searching bits of the messages was this "Device not Migrated" Windows 10 [EXPLAINED & FIXED] I really don’t know how reliable this is; there are other links from searches. At this stage I am guessing the problem is at the Windows end rather than the device

Always problems with windows, but I hate Apple too and Linux is a bit over my head :wink:.
I think the migration error stems from the fact that at first it’s a normal android device and after fastboot, it’s a different device and Windows doesn’t understand,
But how to solve this?

I have found something on the net, maybe this link will help :wink:

When debugging is enabled the phone must come up with that dialogue when you plug in the usb. Maybe try a different cable?

I’ve done the unlocking on a G7 Power recently using a Win10 laptop and all is as described.

The phone did come up with a dialoque when still in normal mode and I alloowed it and checked the box to always allow, but for some reason when in fastboot mode, that does’nt work appearantly

@Privacy-Phone-2022 Thnx for the link. However, I did everything they recommend, but still in fastboot mode the phone is not recognized. I think it has something to do with the fact, that windows does not see the device in fastboot mode as the same device in normal mode.

Ok so the dialogue is working. Make sure you’ve got the latest versions of adb and fastboot on your pc. Hope you get it sorted!

Latest versions are installed. I tried on 2 different pc:'s, but no luck het.

Did you try a different cable? And different usb ports on your pcs?

Yep, the cable is not the problem. Tried different data cables and they all work. I can reboot to fastboot via the command prompt on the pc, so data are comming through. Tried different usb ports and even different pc’s, because I thought maybe some configuration on my work pc would be the problem. But on my laptop it’s the same thing. I think it’s just that as soon as the device is in fastboot mode, windows thinks that it is a different device and it doesn’t assign the right (or any) driver to the device. I tried to install the latest drivers from Motorola, but downloading them I get strange files (test_Download with no appearant extension) that don’t work.

I do not want to repeat things I said earlier with the link but on further reading of it, it is quite detailed and I am not sure how reliable: you already did most of the things he rules out first.

The thing that jumped out at me and he expresses it better, if Windows installs the wrong driver first, in some circumstances it might rule out adding the required “combination” drivers.

Follow his advice first, but essentially I would now remove the device and all its drivers from the PC. Reboot, check the device has fully disappeared.

Now aim to install the best driver first. Maybe he has guidance. One thing to try would be to introduce the device for the first time in Fastboot mode. Again follow his advice first, all my Windows knowledge is second hand.

When I connected the device I could see a driver called WINUSB.inf, but when in fastboot, no driver. But when I disconnected the device and looked at the driver that was installed for the USB port, I saw that a strange driver was installed made by Eset, the company that makes my virus software. On one USB port on the back this driver was not installed and when I plugged the device to that port, it worked also in fastboot mode.
So it was a driver problem. Thaks AIBD, Pinbackand Privacy-Phone-2022 for all the help.
Now I managed to unlock OEM and hopefully the installation wil go flwalessly herinafter :pray: