Moto X Play (Lux) upgrade to Q fails to bootloop in TWRP

just tried to upgrade my Motorola X Play (lux) to Q, using Linux Mint 20. Now I please need help or a hint from a pro.

First try:
Flashing the lastest TWRP (twrp-3.5.0_9-0-lux.img) was successful, also adb sideload for script succeeded: result was 1,00000.

After doing so, I press “Reboot System” => system. This shows the message “No OS installed! Are you sure you wish to reboot?” => Swipe to Reboot
“Warning Bootloader unlocked” is shown as usual, followed by “e” and the bumping point below. BUT about 2 minutes later, my smartphone reboots again starting TWRP. But not TWRP in lastest version (3.5.0). An older version TWRP 3.2.3-r1 now shows it’s options.

Second try:
Using an older version of TWRP ends like first try.

Third try:
Instead of TWRP I use recovery-e-0.14-q-2021020199535-dev-lux.img. Everything is fine, reboot, “e” with the bumping point is shown … but after 2 minutes, my smartphone reboots to TWRP 3.2.3-r1.

Any ideas to escape this bootloop?

Fourth try:
using latest twrp-3.5.0_9-0-lux.img but now instead of the brandnew Android Q image, I servce an older Android N image:

Installation completes successfully, everything works fine. The offered update to 0.14 N also completes successfully.

Any ideas, why the update and upgrade to 0.14 Q fails?

I have encountered this a few times when flashing various Sony devices. What worked for me was formatting - not just wiping - the data partition in TWRP before flashing the ROM. Of course this will lose all your data and user-installed apps, and it may not be possible to restore a pre-format TWRP data backup.

@ petefoth
Thank you for your advice, I’ll give that a try. Fortunately, there’s no user-data on the smartphone …

Next try
I picked the latest files of twrp and upgrade to e014Q at the installation-guide Lux instal guide
After wiping and formatting all data, I started installing e014Q directly inside TWRP.
Again a loop, the jumping “e” is shown for about 2 oder 3 minutes, reboot and again I found myself back in TWRP.
Doing all these steps with e014N is a success and works pretty fine.
Any suggestions or ideas to fix that?

Tried to upgrade to e015-Q, following TWRP instructions.
First attempt: Latest version of TWRP, fails after installation completes ro reboot. The dot under e jumps for a minute vor two, but ends up to reboot to e.
Second attempt: using recovery of e and loading e015-Q from SD card. After reboot, the dot under e jumps for a while, but ends up to reboot to e-recovery. It shows these informations:

How to solve this?

Any suggestions or ideas?

Are you able to run the download manually by browsing to it through the TWRP File Manager…as mentioned here

thanks for the reply. I did a manually download of e015-Q to the SD card. After that, I rebooted to TWRP, followed the instructions of After wiping (first: format data button. second: wipe screen select system + data + cache) I first tried to do the upgrade via “adb sideload”, using Linux Mint. No success. Second try: After wiping data, I started installing e015-Q directly from within TWRP (zip file on SD card).
Next try was doing all this using eRecovery. Also no successful happy end …
Am I doing something wrong in TWRP concerning the wiping? I did it according to the manual I mentioned above.
Greetings Jörg

Hello community and hello @Joerg ,
i have just encountered the very same issues with the lates TWRP and the latest /e/ OS Image.
No matter what i do, wether it being wiping, formatting or factory resetting, it will always eventually get stuck at the intitial /e/ OS boot.
Please help the Moto X Play users :pleading_face:

Check this :