Moto x4 not working with UK sim card

Hey there,

I Installed /e/ on my Motorola moto x4 a while ago and have no issues with it at all using a German sim card. However I got the same phone again but using a UK sim card and this phone freezes some minutes/seconds after using it and restarts. Is this asim card dependence a known issue or does anyone know how to fix this kind of bug?

Best regards


Hi @Mickey ,

Radical solution is factory reset with the sim into the phone,
but you will lose your installed apps, history and customisations.

It should exist something more subtil !..

Wait for advise from another user

Edit : In -->settings -->system -->reset options, you will find
"reset wifi mobile and bluetooth"
It is more subtil … than my first idea ! …

1 Like

Thanks man! Already tried and did not change anything :pensive:

Try to dial *#*#4636#*#* or *#4636#*
will open network settings…(gsm/LTE …)

1 Like

Maybe it is worth checking out the Access Point Name (APN) used by your carrier. They are usually published openly, or usually you can ask the carrier to send the APN to your device.

Personal view, the carrier may expect the APN to be delivered dynamically, but /e/ may interfere with this process. There are a few posts in the #apn category.

The APN already existing on your device should be found in

Settings > Network and Internet > Mobile network > Advanced > Access Point Names

Scroll down to find the selected APN.

1 Like

Hi @Mickey , hi all, I have the exact same problem and would like to ask if you have managed to resolve it yet?

This might be a newbie mistake, but I don’t think I can change the APN settings as suggested by @aibd (thanks for the pointer though!) - the settings are only available once I insert the SIM card, but when I do that the phone freezes and restarts within a second or two, not long enough to actually change the settings. (I’ve also tried factory reset and reset wifi mobile and bluetooth, no luck! Also, I have tried several SIM cards and the problem persists.)

1 Like

This can be a little hard!

You need to be online, perhaps with a good WiFi connection and no Advanced Privacy switched on.

As you try to save a new APN connection, your “new” settings will be checked (by WiFi) … only a valid APN will be accepted.

Having the carrier send the APN to the phone is the easiest method.

Well … yes, I find it best to install /e/ with the SIM card present

1 Like

Thanks for the quick reply - I’ll try changing the settings and if all else fails reinstall /e/ with the new SIM card inserted!

1 Like

So … same device, UK SIM card.

maybe it is a problem with the build? idk.

1 Like

@micau thanks man for shring! Same problem that it freezes before you can change the setting but yeah thanks for the advise @aibd !

Unfortunately I currently do not have direct access to the phone so I can only try simple fix attempts. I would probably also try to install lineage os to check whether it is also an upstream issue.

Anyway @micau I would really appreciate it if you could post progress on possible fixes here :blush:

Just as a quick update, I reinstalled /e/ with SIM card inserted - but the problem is still there :frowning:

I have found the right APN settings but can’t change the settings on my phone in time before the phone freezes.

Also, in case it helps: yes, it’s also the Moto X4, I’ve tried different (UK) SIM cards that should be supported, but I run in the same problem with all of them. With no SIM card inserted, the phone seems to work perfectly fine.

Any ideas about what to try next very welcome :slight_smile: Thanks for your suggestions so far!

1 Like

With a 100% known APN, no SIM card inserted, Advanced Privacy turned reliably OFF, a good wifi connection …

Can you use the ADD button (rather than edit existing) to save a new APN settings?

… just a thought … if you can get the APN saved under these conditions (untested!) perhaps the SIM card can then function?

And / or, perhaps you could work towards Create a log @/e/ for this crash. If a logcat is new to you, I suggest practicing when no crash or freeze will happen … then move on to trying to collect a logcat when you expect the issue to appear.

1 Like