Motorola g 2014 "titan" - problems with the boot loader

edrive setup? what is it?

That’s the account manager.
Settings - accounts - /e/

Where have you logged in on browser ?
In or not ?

And the system doesn’t recognize my sim card (there aren’t contacts on it, i can phone nobody and so on…).

Ok, and you can login on with the browser on phone with the same creditentials :thinking::thinking::thinking:
That’s really crazy.

It looks like the modem firmware isn’t working, because your SIM isn’t working.

no, i just noticed that i can login with the browser on my mac, but not on the phone.
modem firmware?

Yes, I think you aren’t getting any internet connection on your phone. Try open any website on the browser. I think it won’t open

The only solution which could eventually work is
Going back to the same stock android version as eOS is. (I think it’s Android7 nougat).
When stock android is the same as eOS version, than flash eOS again.

no, i can open webpages on the phone.
I can’t login e.mail :crazy_face:

Wrong modem firmware :-1::weary:

It seems that there is no nougat stock rom, but here are modem files. Check if you find your model on android7 section

This seems to solve the bootloader problem.

Mhm… yes, I solved installing android 6.0 (as you suggested) and then following the normal procedure of installation for /e/.
But now, the sim card is not detected, the account manager doesnt’ recognize my e.mail account and so on…

Anyway thans for your help!

I think we have finished this discussion / issue. Your issues are comming from non working modem / missing firmware. The onyl Android version where it was working is the old stock rom. Or am I wrong ??

Yes, I think so too.

Anyway, thank you for the support!

Your bootloader problem seems to be solved?
Last bootloader version for Moto G 2014 (XT1068 - Titan) is 48.87 (sha-1b80345, 2016-06-30 15:51:10)

If you want to flash the last modem BLOB then do this:

  1. Your bootloader must be unlocked.
  2. Always use latest ADB and fastboot for Linux, Mac or Windows. Unzip into a subdirectory, maybe “ADB”.
  3. Search for the last Stock-ROM for 6.0.1 (Marshmallow) by Motorola , e.g. “” an unzip into same subdirectory. RETEU won’t work because it only supports 5.0.2 (Lollipop).
  4. Enable deverloper options (I don’t know the exact English expression, in German “Entwickleroptionen”) and there enable “Android-Debugging”.
  5. Then boot phone into bootloader; when in bootloader connect phone to PC via USB.
  6. Open a shell in your subdirectory and type or copy/paste one after another to see if the command is successful:

fastboot devices (–> only to check if your phone is detected and ready)

  • If device is ready then flash the modem BLOB:

fastboot oem fb_mode_set
fastboot flash modem NON-HLOS.bin
fastboot erase modemst1
fastboot erase modemst2
fastboot flash fsg fsg.mbn
fastboot oem fb_mode_clear
fastboot reboot

  • After reboot the modem should be working.
  1. If you want to flash the bootlader:

fastboot oem fb_mode_set
fastboot flash bootloader bootloader.img
fastboot oem fb_mode_clear

Beware: Maybe the internal sd-card (you personal data) will be erased - I can’t remember, it was too long ago. So backup your data …

Edit: If you flash the bootloader to a new version you can never go back to a previous Android-Stock-ROM version because the bootloader is “build”-dependant. Doing so could brick your device.