Motorola G7 build

I wrote up some information about how to install /e/ on the G7 and variants like the G7 Power.

Here is link for the unofficial build:

According to @Manoj , the Motorola G7 and the G7 plus is going to go live as an official build 3rd quarter of 2020 (weeks away):

Let’s celebrate! when the official build is released. :tada:

1 Like

Moto G7 Power (Ocean) and Moto G7 Play (Channel) are now officially supported by Lineage.

1 Like

I would like to request support for the Moto G7 Power also.

1 Like

+1 for Moto G7 official /e/ support!

1 Like

Just last week installed /e/ (the version found in these fora: 10QQ3A.200805.001 20201212.205157 test keys) on moto g7 power - ocean (in particular, xt1955-5 from a US metro store); metro service seems to be working fine so far, although some device issues have arisen (aside from a bad key warning whenever I start the phone… I have also messed with settings to try to alleviate these issues):

  • occasionally the screen drawing will go wacko (I just toggle setting again in displays->advanced->colors),
  • USB file transfer seems to pause for about a second after every file! so it ends up being slower than expected,
  • phone calls force the screen to go black, and it can not be turned on until the other caller hangs up… so no entry of number options,
  • I haven’t found “swipe typing” (maybe that feature is too google?), and next word suggestions don’t come up),
  • and the notification light --which I’d never seen before!-- is not responding to my requests for it to go off or at least go dimmer.def would love some moto g7 power support; I’m running an xt1955-5 on the unofficial build and the screen goes black during calls, so it can’t be used for speaker or number entry… I’ve posted that issue elsewhere, just FYI


1 Like

Hi, I am seeing the builds available for G7 Play but when I tried updating the build with fastboot, it fails to install.
At closer inspection, it looks like the model number of my phone is not in the list - ZY323TZDP3
I am not sure what is the difference here. Does anyone have any clue?


Hate that no one has answer yet, but really I haven’t the foggiest… Staying tuned…

In other news:
Resetting messages cache worked to get my messages going back to where they were supposed to

Screen issue no longer! Idk how that happened,but I think the first time it worked may have been on signal, then others started working, although if I recall some were stubborn for a bit… Now signal has echo issues though where it didn’t before (and I’ve read someone else had a similar problem)

Still wondering about swipe type…

I’m following this thread for a ‘daily driver’ device that yearns to be liberated.

Model: Moto g⁷ power
Hardware version: PVT1
Model Number (SKU): XT1955-6
Carrier: Verizon

Current device build:


1 Like

We’re is the link for the power /e/rom

1 Like

I think it’s at

If there’s a newer one, I haven’t seen it…

I got that from this thread:

+1 For an official Moto G7 Power build


+1 for the G7 Power!

It’s officially supported by Lineage, and you already support the other G7 series phones, so it would be great to add the G7 Power as well. Thanks for the consideration!

1 Like
  • 1 for Motorola Moto G7 Power (ocean)

It would be great to use it as a daily driver with /e/ on board.

1 Like

E-love, I have been using LineageOS on my Motorola G7 Power for a couple of months so far. From what I practiced and learned from internet foums, issue with colours (setting again in display->advanced->colors) is quite common for this device. I wonder if it is not working on Lineage, will it work on /e/ ?
I believe that screen issue during a phone call is more problematic.
Currently I had to switch to another device so I could start using /e/ in practice and so far I have started looking forward for option to go back to Motorola G7 Power however with /e/ on board.

1 Like

Yeah somehow the phone call screen availability resolved itself…! The colors are still an issue off and on, but the big remaining problem for me is having to install a third party app in order to backup texts/calls because the stock app “backup” button is non responsive… (esp relevant because recently, my texts have been incoming to the wrong threads although outgoing is no problem, so I need to reset settings…)
All told, OK, but would def appreciate more support

Thank your for your effort in the first place. :heart: I just wanted to let you know that in LineageOS the glitching colours is not solved yet as well :sweat_smile: I am not a developer, but I also learned a lot during last sligthly over a year in order to divorce Google and Facebook. The question is, if any help I can offer in this situation :thinking: Another tricky point is the fact that my Moto G7 Power is my only phone/daily driver … :face_with_raised_eyebrow:

Oh yeah, I think the main help most of us here can offer is just staying updated when news comes out…

E.g. just today I got a message from metropcs saying that my VoLTE settings might be interfering with my service quality, for which they suggest an update, but they don’t have one for Motorola (other than oneplus…); I’m not going to mess with it until it says “are your texts arriving to the wrong threads?”, which I doubt will happen at all, soooo…

I d k about others here, but I’m getting terrible data service (esp pdanet, which no longer works at all on this phone, and although pairvpn was supposed to replace it, my laptop is too old for that solution), and it seems like every 6 months or so, metripcs has for some new data services problem for me to solve (pushing me it feels, ever closer to their unlimited plans)…

I imagine this has something to do with /e/ being installed,and more particularly i bet a locked bootloader (which is not possible with the current rom) would help me avoid more network issues than just those with pdanet…

Is there a fully supported motog7power ROM that I’m missing around here?

This from manoj regarding upgrading to /e/0.19, i.e. “android R” (i.e. 11):

“Any OS version upgrade will require installing the latest stock ROM first to get the correct firmware. Always check that it is the same version of the OS. If as in this case the same Android 11 stock is not available the next best option is to get the latest stock 10 OS first and then /e/ R. Once you have /e/ R the next builds will be OTA.”

Just FYI (i ran into it while trying to follow the upgrade instructions that say you need the stock rom)

wanted to confirm a few things FYI about /e/-19 install

Of note, I was upgrading from /e/-13 so I’d basically already done the first few steps of

This time (without having installed the most up to date android stock rom because it kept throwing various errors depending on how I tried), the first attempt to flash /e/-19 seemed successful, but I started getting errors loading files back onto my device as though it didn’t have enough room and the unlock pattern was not working

The second time i tried to format and flash again I went up through the point of copy-partitions, then instead of /e/_recovery, i used twrp 3.5.1_10 to wipe as much as I could, and installed /e/-19 from there.

When i used twrp to boot into slot B, it gave me the /e/-19 welcome screen (as expected, all good), but using twrp to boot into A gives me a boot loop even though I can boot into recovery from the bootloader to /e/-recovery, which itself tells me “active slot: a”, (previously it was b), but so far no problem as long as i can get ota updates that don’t break anything…