Motorola G7 Plus – First / e / Phone and some troubles

Hi everyone,

I am glad to be part of the / e / community.
I installed my first / e / OS on a Motorola G7 Plus few days ago.
That was something new to me. It took me a lot of time to understand how it works.

After a lot of research I did it.

So I followed the process available for the G7 Plus from / e / documentation.

I enabled USB Debugging and OEM Unlock and unlocked the bootloader.

Here is what I have done :

For temporarily booting on a custom recovery using fastboot :

I tried “twrp-3.5.2_9-0-lake.img” but it did not work so I used “twrp-3.4.0-0-lake.img”

Then I installed :

Followed by : adb sideload

and : adb sideload

I was stressed and finally the phone started on / e /

Here are my troubles :

  • The following message appear when I try to open some apps : “ keeps stopping”

  • Impossible to connect to a Wifi : “Failed to save connection”

  • No gallery app available

  • Is it normal, I still have some Google App on the phone : Voice Search, Google Play, Google Play Store, Google ?

Was it a mistake to use a different “twrp installer” version compared to the “twrp.img”?

I have to precise that the phone has never been used so no update of the phone before installing / e /

Should I restart everything and use the first version of / e / and then applied the newest version directly on the phone?

Thank you for your help.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @SkyWeb, welcome. Yes, this is the mistake. You want to flash the twrp_recovery.img NOT .zip. This flash is used temporarily to sideload the and then finally the /e/ . The final /e/ writes over the original twrp_recovery.img with a permanent /e/_recovery file which you can verify after you reboot the system at the last step.

@newts anything you would add as you just completed this?


I will check the actual versions I used when I get home later. It was this step where I was hung up originally trying the /e/ recovery tool. After the tips above I went with twrp instead and the sideload of the partitions hack and the final /e/ image went smoothly.
I also had a problem that I think I solved then where it was really flaky until I switched USB cables from the USB port on the laptop to the one on the dock (Lenovo).


Thank you for your answers :+1:

It will help me a lot, I am away for the next two days.
I will try again, and this time not use the “”.

Something I did not mentioned is that I also tried first the /e/ recovery tool with no results.
So I moved to the “twrp.img”

I did everything on my laptop with Ubuntu 18.4.5

1 Like

NO, it is anormall !

are you shure you have tapped format /data and typed yes to confirm ?
are you shure you have wiped /system, /cache, /davilk-ART-cache


Great what @piero points out :point_up_2:. Be sure you wipe all those partitions or data from your previous ROM will still be there. :point_down: @SkyWeb

1 Like

After reviewing the installation directions I am near positive that I used the temporary recover file labeled twrp-3.5.2_9-0-lake.img 2021-04-05 on TeamWin’s site. Of course I can’t verify this now because when /e/ was flashed the /e/Recovery was part of the flash wiping away the temporary TWRP flash (picture below :point_down:). Sorry I can’t remember 100% but I believe once you go through it again with @piero 's and @newts ’ direction you will have success. If not let us know and we will help guide further. :+1:

1 Like

I am sorry I didn’t keep good notes but I do have a Bash history. Here is what worked for me at the end (much previous failure redacted). It looks like I had slightly older version of twrp? probably doesn’t matter.

660 adb reboot recovery
661 mkdir twrp
662 mv ~/Downloads/twrp-* twrp/
663 cd twrp/
664 unzip
665 adb reboot bootloader
666 fastboot devices
667 fastboot flash recovery twrp-3.5.2_9-0-lake.img
668 fastboot flash boot twrp-3.5.2_9-0-lake.img
670 cd …
671 adb sideload
672 adb sideload


I everyone ! :wave:

Once again thank you for the time you take to help me.

I came back home yesterday night, I turned on my computer and looked at our discussion.
@piero : Yes the first time I did format/ data and typed yes but I do not remind my if eventually I forgot to wipe something.

So I tried what @egx470 recommend, not install “”
And finally, everything went faster.
/e/ is perfectly installed, no more Google app on the phone and I am able to use the wifi.
And thank you to newts, it is clearly easier to read all the command as I am not used to. :grinning_face_with_smiling_eyes:

It a pleasure to see a reactive community !
Thank you :pray:


This looks to me like you flashed the /e/ ROM over the stock firmware, without formatting the data partition. So you still have some software from the stock ROM which won’t work with the /e/ ROM


@SkyWeb glad you got it squared away. I find the G7+ to be an excellent “bang for the buck”. I picked mine up for $120USD (new) and in my opinion it is worth much more. Enjoy!

Thank you,

Your are right, initially I planed to take a refurbish Samsung S7. But I found this new G7+ on sale around 124€ (146$). I looked at /e/ website and found that it was possible to use it.
I my mind it was: "Hey, it’s cool, let’s try! :joy:
No regrets :+1:

1 Like