Motorola G7 Power XT1955-5

Hi all,
This is my first post. Just found out about this project today. I looked on the supported hardware list and found several Motorola G7 models supported but they are all XT196X models. It didn’t list any XT195X models. There was also a Beta tag on the listing. I’m looking to see if there’s any support for my model and if anyone has tried to load it with /e/. Also wondering why it’s listed as Beta.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Did a search and found my answer. Sorry for the extra posting.

Anyone else looking for this, you should look at the post titled “E on moto g7 now installed”.
In it Manoj replies “Devices already with official LOS support are easy to build and will all get on the supported list. I think Moto G7 power is also supported so should be getting an /e/ version as well. Do not have the dates as yet.”

So, bottom line is anyone with a G7 Power just has to be patient and wait for the build.

the unofficial one is working, no need to wait

Just installed it, works well, no issues. Thank you!

1 Like

Wow, not my experience… Don’t you have calls blocking the screen in darkness? I.e.when making or receiving calls, I can’t see anything after hitting call or answer, respectively… I have about 3or 4other issues (posted in that link above if I recall, if not, I’ll edit), but ultimately none are dealbreakers… Official support would be cool though

1 Like

Hi E-love, When I initially installed E on the G7 I did not setup a security password or screen lock and had no issues. Since then I have added a password to the phone and it does get in the way after connecting a call. I should have logged in and updated my comment. The calls still hang up okay, I just cannot get to the hangup button. That is the only issue I have noticed on the G7, I do not have any issues on the G7 Power. Before I installed E I I did a factory reset on the phone, it was a clean install.

1 Like

Huh OK gotcha
I also did a clean install… I’ll try without a password and see of that helps…

Tried it, but no go, dark (unresponsive) screen during calls persists
Just FYI

So I installed this on one of my G7 Power’s and have had no issues. Calls are fine but I have no password set up and did an install after factory reset. I had to switch back to my other phone because of apps I needed for work I haven’t installed yet. I’ll see about switching back and seeing if I can duplicate your issues.

1 Like

Just to be clear, are the issues on the G7 Power or the G7 or both? Not too clear from the posts.

1 Like

Oh nice you got it working!
G7 power from metro xt-1955-5

Wow, and now texts are coming to the wrong threads… This is interesting

I am having the password screen in the way issue on G7 but not on G7 power.

An update:

Resetting messages cache worked for messages

Screen issue no longer! Idk how that happened,but I think the first time it worked may have been on signal, then others started working, although if I recall some were stubborn for a bit… Now signal has echo issues though where it didn’t before (and I’ve read soenine else have similar problem)

Will post back in other thread too

Messages backup and restore screen non-responsive (except for “restore”, which finds no backups -because there are none- but can’t back out or cancel…)

Incoming messages going to wrong threads again… Resetting cache did NOT work this time…??? (also did not realize clearing cache would also clear so many photos…terrible mistake)

Plus backup not working makes it especially painful to deal with

This from manoj regarding upgrading to /e/0.19, i.e. “android R” (i.e. 11):
“Any OS version upgrade will require installing the latest stock ROM first to get the correct firmware. Always check that it is the same version of the OS. If as in this case the same Android 11 stock is not available the next best option is to get the latest stock 10 OS first and then /e/ R. Once you have /e/ R the next builds will be OTA.”

Just FYI (ran into it while trying to follow the upgrade instructions that say you need the stock rom)

Just wanted to confirm a few things FYI about /e/ 19 install

Of note, I was upgrading from /e/-13 so I’d basically already done the first few steps of
This time (without having installed the most up to date rom because it kept throwing various errors depending on how I tried), the first attempt to flash /e/-19 seemed successful, but I started getting errors loading files back onto my device as though it didn’t have enough room, yet I couldn’t find a place to check the remaining space… Then the pattern screen lock I’d set wasn’t working (could’ve been user error, but I’m quite careful about that), so i had to reflash anyway.

The second time i tried to format and flash again I went up through the point of copy-partitions, then instead of /e/_recovery, i used twrp 3.5.1_10 to wipe as much as I could, and installed /e/-19 from there.

When i used twrp to boot into slot B, it gave me the /e/-19 welcome screen (as expected, all good), but using twrp to boot into A gives me a boot loop even though I can boot into recovery from the bootloader to /e/-recovery, which itself tells me “active slot: a”, (previously it was b), but /e/ seems to be working again… I’m guessing a second set of slots maybe been constructed in there?? Anyway so far no problem as long as i can get ota updates that don’t break anything…

I’m concerned about the space issue, but I’ll report back to this or similar threads.