Motorola Moto G100 recovery image doesn't work

Hi. I just got a Motorola Moto G100 and I am trying to install /e/ into it.

I’m following the documentation, unlocked the bootloader accordingly to Motorola documentation.

There is a part in the install doc, where I need tp upload a recovery image to the phone, and sideload a zip file to synchronize the A and B parts.

After loading the recovery image though (the on provided by the link in the documebtation), I try to boot the phone in recovery mode, and it simply get stuck in the Motorola’s boot logo.
Does anybody know how can I proceed? Maybe the recovery image provided is broken? Did I do something wrong?
I can still restart the phone, enter in the bootloader, etc, but attempting too boot the phone in recovery mode, or in normal mode, simply does not work. Any ideas?

I did:
$ fastboot boot

As the doc says

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Just to rule out …

did you ensure

Caution: Do not install /e/OS on top of a higher version of stock OS. Before installing /e/OS ensure your device has the latest stock OS of the same version as /e/OS. If only lower versions of the stock are available then install the last available lower version before installing /e/OS.

Did you double check

Tip: Outdated fastboot releases dropped legacy A/B support, so it might attempt to flash to boot__a / boot__b rather than boot_a / boot_b if you try to flash boot. In this case, you must update fastboot to a release newer than or equal to 31.0.2. Alternatively, you can manually specify which slot to flash to based on what slot fastboot failed to flash to. For example, if fastboot fails to flash to boot__a, you must flash to boot_a.

Actually I see:

  • Manually reboot into recovery mode

in Install /e/ on a Motorola Edge S / Moto G100 - “nio”

Hi.

Yeah. I kept the phone in android 11 when I started the installation process.

I used the latest platform-tools available, but I dont think that the platform tools version is a big deal here anyway, as I didn’t even start to flash the OS. Tje recovery image itself didnt work.
I tried to boot the twrp recovery image and it booted.
The one provided within tje documentation seems to be the problem.

The twrp image had its own problems which I still didnt have time to look into yet, but it at least booted

So, I finally managed to install it. And I still think the recovery image pointed by the documentation is broken, although I’m by no means an expert to confirm that.

TL;DR;

I installed TWRP in the phone, and installed LineageOS 18 via sideload, which worked fine. The recovery image Lineage .zip file install, seems to be the same one /e/ requires. So, after I installed LineageOS, then I rebooted the phone in recovery mode, and followed the remaining steps in /e/ Doc to sideload /e/ image, and it’s now working fine.

Some more details:

I noticed the documentation is very similar with LineageOS install documentation, and I wonder if the recovery image provided in the /e/ documentation uses the same recovery image as Lineage, because I did try the recovery image provided by the Lineage documentation, and I ended up in the same situation. Only using twrp I managed to upload lineage to the phone and install it. Twrp sideload function seems broken, so I needed to first upload the Lineage image to the phone, then install it. I tried to install /e/ before, in the same way, uploading /e/ image and installing it with twrp, but I ended up with a “no operating system found” message in my phone :stuck_out_tongue:, and I needed to flash the stock image before trying to install Lineage.

Hey it looks like I’m having the same problem you went through. Did you ever find a solution to install /e/? I’m trying to go through lineage as well but running into the same problems of not being able to flash a recovery. My output says invalid partition name recovery. What was the final work around you settled with?

Also I looked on the TWRP website and didn’t see a version listed for the G100 or Edge S, did you use a different version?

It’s been a while. I think I found a custom twrp version for moto g100, then I uploaded the lineageOS image to the phone, and via twrp interface I installed it.

Yeah I just found an unofficial version of TWRP on XDA. So you loaded the lineage recovery image and then installed that over TWRP, like replacing it? Have you made your way to /e/OS?

I have fooled around with this stuff before with older phones and tablets but this invalid partition recovery and not being able to even flash a recovery is getting really frustrating.

Yeah, I’ve been using /e/ into this phone since then.