MS Outlook and Teams account login not working since latest upgrade

Hi folks,

FairPhone 3
/e/OS 1.7-20230110250404

On my /e/ os on FairPhone 3, after the latest upgrade [at least I think thats when it happened], I’ve lost the ability to sign in to my Microsoft Outlook and Microsoft Teams apps. I need these for work (Im not proud of it, its just a thing).

When I now sign in to either of these apps I get a (No network connection - Please check your network settings and try again [2604]). This looks like a Microsoft error.

I was just wondering if anyone else was experiencing this?

I have deleted the apps, cleared the cache, deleted the accounts. Nothing lets me back into these apps.
I have tried to sign in on different networks, 4g, wifi, different locations.

Any thoughts?

Apologies if this is nothing to do with /e/ OS, but I lost connectivity just after the upgrade.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Yeah, that hit a few of us actually.
Check Advanced Privacy. It, for me, was blocking everything. When unblocked all seemed good.

In the Telegram group it was suggested to unblock “Mobile Engagement” (for Outlook anyway).
Try that first. Otherwise unblock all and test. You can then re-block individual trackers.

Oh, and search is your friend. A few threads already covered both apps.


Thank you for your suggestions. Much appreciated.
I guess I wasn’t putting the words in the right order for seach.

I got the same error in Microsoft Teams. Going to Settings > Advanced Privacy > Manage apps’ trackers > Teams and unblocking “Mobile Engagement” lets me use the app normally now. Thanks to everyone here and in Microsoft Teams - There was a problem with the network. Try signing in again - continues - #2 by Raffael for the tip!

1 Like