Murena Fairphone 5 slow charging speed

I am facing issues charging my Fairphone 5. I’ve tried with several good quality chargers and different cables, and consistently get very slow charging times.

The Settings > Battery screen usually indicates a charging time of around 3hs. I also used AccuBattery to measure charging speed with the screen off. Here are the results:

With the Lenovo laptop charger (and its non-replaceable cable), AccuBattery reports a charge speed of 2016mA average with screen off. It indicates that charging completely will take 1h49m. This charger reads:

Output: 20.0⎓V 3.25A 65W / 15V⎓3A / 9V⎓2A / 5V⎓2A 10W

With an Apple 87W charger (with an Apple cable), AccuBattery reports a charging speed of 2020mA with screen off. This charger reads:

Output: 20.2V⎓4.3A (USB PD) or 9V⎓3A (USB PD) or 5.2V⎓2.4A

With a RAVPower PD 65W charger (with the FP cable), AccuBattery reports a charging speed of 2018mA with screen off. This charger reads:

Output: 5V⎓3A, 9V⎓3A, 12V⎓3A, 15V⎓3A, 20V⎓3.25A, 65W Max

Apparently, charging speed is capped at 2020mA, regardless of charger and cable that I use.

I initially reported this in the Fairphone community forums (this is also where I was advised to try using AccuBattery), but nobody else seems to have this issue. The only factor that varies between my test device and other devices is the OS.

Is anyone else having issues charging a Murena Fairphone 5? What do charging times look like for others?


I faced the same issue few months ago and… I had difficulty to understand this issue on my working huawei psu.

Finally I bought the official fairephone 5 charger and USB cable, it works perfectly.


Is that this charger? Is this a Murena FP5 too?

The site says it’s a 30W charger, which is less than 50% of any charger that I’ve tried. I have like half a dozen at home and I can’t believe that they’re all faulty, and somehow work fine with other devices but not with the FP5.

I wonder if maybe I have a faulty unit.

Yes it’s that one.

I was sceptical too, in my case I bought it (with the usb cable) and it worked.