MySudo on Android - looking forward to a working version for /e/

Hi all.
Recently the MySudo app from the iOS ecosystem was finally ported to Android. :+1:

Naturally, I tried to install it on my /e/ device, by using Aurora Store to download a copy anonymously from the G Play Store (I don’t see it in any other store that I’m aware of). Sadly, the app never manages to get past the opening splash screen - unless there is then an error message that the

“microG Services Core has stopped”

and an Open app again icon.

No amount of restart/opening microG works, so the app hangs at this point.

Hence, my question is around whether MySudo is likely to be usable on /e/. Given the close resonance of the philosophies of /e/ and Anonyome Labs, this would seem to be a match match in privacy heaven :laughing:


Despite how the app is described, it is totally dependent on Google.
First I was wary of the Braze/AppBoy tracker (search for them on the web) from the get-go.

Recorded the crash. Logs full of entries showing it needs or tries to access safetynet, firebase cloud messaging, braze servers, and all kinds of other stuff.
Aurora Store shows that it is GSF dependent but that doesn’t always mean an app won’t work but in this case it is highly dependent.

Safe to say it’s a no-go on a Google free setup.

I tried to scan it using Exodus-privacy, but it was not able to download the apk.

It might still be possible to have it run on a minimally-Googled setup, using microG, for example, but - yes, you’re right - it does go against the core idea of a Google-free setup.

But, we can hope… :wink:

Not sure what minimally-Googled is but I just tried it on a ROM with microG and Play Store and it still doesn’t work. Logs show it definitely needs SafetyNet. Loads of errors regarding that before it gets to other issues with FCM and accessing the Braze servers (maybe adblocker-related but haven’t checked).

Given the current issues with SafetyNet it’s going to get worse according to this article…

SafetyNet’s hardware attestation will make hiding root in Magisk really hard

What I meant by minimally-Googled is that it would just run microG and nothing else, albeit suitably modified by the developer for such a minimal surface. Unlikely they’d do that, though, admittedly.

So, it seems that if one wants to use MySudo, it will need to be a choice between Apple and Google, neither of which are particularly appealing; though, in this regard, Apple is the lesser of two pretty big evils.

Seems that if I want to use masked VOIP phone numbers to avoid giving out the real SIM phone number, I’ll have to use a third-party provider (such as Twilio) and roll my own setup. Hopefully that will be easier than the (somewhat fraught) process of getting /e/ onto my Sony XA2 in the first place :grin:

Thanks for all your detective work, BTW :+1:

1 Like