Native dialer failing SIP registration

I am having trouble with getting the native dialer to register successfully to a SIP account. I know the credentials are correct because the Grandstream Wave app is able to connect to the SIP account.

Suggestions on how to troubleshoot this?


Probably this app looks for ‘gg plaie services’ and microG can’t completely spoof…

Have a look to microG > Settings then microG > Autotest (wait a few seconds for location).

You can also try to add a gg account from microg settings (or Accounts), but then ’The wolf [wiil be] in the sheepfold’…

Native LineageOS / e-OS dialer app needs GApps?

Anyway, I’m not so familiar but I don’t see a problem.

No location for microG (last entry).

And that’s probably grandstream wich needs ggPS…

Because I have location disabled. When enabled:

And I’m confused… I mentioned grandstream is working fine while the native dialer’s SIP functionality is failing.

So I misunderstood, sorry.

No problem. Any ideas about the native dialer? It does not expose many SIP settings from what I could find.

No, sorry.

Perhaps have a look at Settings > Apps > Phone then Permissions > 3 dots > All permissions then back page…

Hmm… what am I looking for?

And wow, there are so many layers of settings pages.

Seeing what permissions do and then try to enable missing ones. Not sure it solves your problem, sorry.

I don’t see how it would, but I enabled location and storage permissions for the phone (dialer) app and tried again. Still not connecting to SIP account.

Solved. The problem was with special characters in the password, maybe like % or /.

So somewhere there is unsafe handling of inputs… Secure passwords fail again (you’d be surprised how many sites handle passwords very poorly). This was affecting other SIP clients too other than the native dialer, such as Linphone, Mizudroid, Jami. Grandstream Wave is apparently more robust in this respect.

After setting a simpler alphanumeric password, there is no problem with SIP registration with any of the clients.

1 Like

This topic was automatically closed after 60 days. New replies are no longer allowed.