Need Google Play Services for bank app

My bank (Triodos UK) has shifted to a mobile secure key, and I’ve been trying to activate it for a while, but it always throws an error when it comes to uploading a video of my face for verification. Recently, it showed that I need to download Google Play Services, which I guess is why I’ve been getting the error. Is there any way to get around this, I can’t find Google Play Services on Aurora (v4.1.41), if I get Google Play Services off another Android phone via a sharing app will this work? Or should I tell my bank to re-work their app so it works without Google Play Services??

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

/e/OS includes microG already, which poses as Google Play Services, but it’s of course not a 100% exact replacement, and you can’t replace it in /e/OS with the genuine Google stuff. Many Google-dependent Apps work just fine with microG at a point in time, some don’t.

You can do that, and then you can have a good laugh about it together with your bank, I suppose :slight_smile: .

Which /e/OS version on which Fairphone are you running? Please refer to this here …

You might also look for clues here …

1 Like


According to plexus, the app have to work well when µG is activated:
But this is not 100% accurate I guess, depends on update and so on.
EDIT: Triodos bank analysis by plexus is from 2020, so it’s probably outdated.

But this:

is totally freaking :fearful:

Maybe one day Google will leave it’s hegemony as Gael says:

Thanks, I thought it wouldn’t but don’t really know too much of the background tech stuff (about microG) and just wanted to check.

Could at least try haha, they’re supposed to be an ethical bank though I suppose their ethics wouldn’t extend to FOSS and de-Googling…

Apologies, should have made it clear. I’m using FP3+ (I think, or it might be FP3), /e/OS 0.14-2021012698290. Okay I’m realising now that my /e/OS version is rather outdated, maybe if I give it an update to 1.7 (the latest? or 1.5?) the bank app might work…?

Yeah, the bank app worked fine until they required this mobile secure key and it still works fine apart form this mobile secure key thing.

:grimacing: it’s not uncommon though, for other digital banks like Monzo, uploading a video of your face to match your identity documents is common practice.

One could hope I guess, but I think it’s unlikely. Google does make life easier for most people, for whom privacy or hegemony is not an issue, and who don’t know/understand this kinda tech stuff. I barely have a grasp of how it works (& my work is mostly computational)…

1 Like

Yes, there’s a chance it might work, because the included microG gets updated along with the OS, and a current microG should be the best chance for App compatibility. If the current /e/OS 1.7 is on offer for you, I’d go with that.

Be prepared for some changes, taking such a large update step.
Especially this … Advanced Privacy - know all about it

1 Like

Yep it’s a good idea :wink:
You can jump directly to 1.7.

1 Like

I don’t see 1.7 under the System Updates, so might stick to 1.5 for now…

Great thanks, will update again if it works!

I’ve installed and rebooted to v1.5, but sadly the bank app still tells me to install Google Play Services to proceed. This is rather frustrating, I’ll try taking it up with the bank and see what they say…

I guess you have /e/OS Q (Android 10) DEV installed on your phone, right?

1 Like

I have Android 10 and it says /e/OS 1.5-20221031230909 but I’m not sure about Q or DEV… (sorry I’m not very familiar with Androids or with /e/OS)

Check the reply of @AnotherElk

[HOWTO] Give complete /e/OS version info easily for support, answers, comparison etc

1 Like

My bad (please bear with me while I get my etiquette up to scratch), but you are right, I have the /e/OS Q (Android10) DEV version: 1.5-q-20221031230909-dev-FP3

1 Like

Currently the /e/OS dev release channel prior to Android 12 (S) has no chance to pass Google SafetyNet by default, which is a requirement with many banking Apps.
Adding this to the /e/OS dev builds (and breaking a different feature in exchange) prior to Android 12 (S) is currently in discussion here … and you can vote …

1 Like

there’s no entry yet at microg issue tracker for “com.triodos.bankinguk”.

You could observe adb logcat (see howto) output while you interact and try to either take the photo or when sending it off. It will - in dozens of lines and sometimes rather convoluted - tell you what exactly it is failing on. This would be the basis of a report to microg if it is at issue.

Over time there is a chance it is addressed while implementing parts of play services.

Maybe a stable version of /e/ could work with your bank app, as it pass safetynet detection.
If not, or if you choose to stay with dev, “universal safetynet fix” module of the “magisk” app should do the trick. [Howto] install magisk and hide that OS have been modified

I would advise the same, also because v1.5 for Q on FP3 is the last release and so you will have to upgrade to R anyway if you want to keep receiving future updates.

I run LienageOS for MicroG, and I get the same response. I just logged into my online banking account via a web browser and sent the following message:

Subject: Mobile app


I am trying to set up the mobile app on the Android phone, which runs
the LineageOS for microG operating system[1] - a privacy-respecting
phone custom ROM providing “The full Android experience without
Google Apps.”

When I reach the point where the app wants to record a video of my
face, the video screen appears briefly, then I see a screen saying
“Please install Google Play Services to continue”, and I am unable to
progress any further. The phone OS does not include Google Play
Services, and they cannot be installed.

Please let me know how I can use the app *without Google Play

Thanks very much

If I receive any reply, I will post it here


is really safetynet at fault? I’m not convinced. If it doesn’t say so in the error message, only logcat will give more insight.

@jssze could you document the exact error message wording when the upload fails? and is the adb logcat something you could do?

Without an account + verification code by the bank it’s not possible to reach the video upload to debug myself