Need help recovering Murena One


Last night I attempted to update to /e/OS 1.9 beta, and once it was downloaded I installed and it failed and entered recovery mode. I attempted to wipe all data and recover again and am unable to. I have attempted to follow the steps below but have several issues

Issue 1: I attempted to sideload the zip file via Apply Update via ADB, but I am getting the error that it is unable to find file META-INF/google/com/android/update-binary

Issue 2: I am able to use adb when I click “Enable ADB”, and the Murena One instructions above state to boot into fastboot mode. When I do boot into fastboot mode, it seems that ADB is no longer enabled and I cannot continue with the recovery steps such as unlocking the bootloader

If I go into the recovery menu and enable ADB, I can issue commands and even enter shell. Is there a way to place the files this way to recover?

Any help is appreciated, thank you!

Using “recovery” and “adb sideload” should work using an ota build

No matter which version of /e/OS I try to sideload, it’s the same error

Now send the package you want to apply to the device with "adb sideload <filename>"...
Supported API: 3
Finding update package...
Verifying update package...
E:footer is wrong
Update package verification took 0.4 s (result 1)
E:signature verification failed
E:error: 21
Installing update...
E:Failed to find update binary META-INF/com/google/android/update-binary

What recovery and what recovery version do you use ?
Have you tried to install from the device ?


Murena One is sold by Murena, so you may request help by email from