Need some help with custom recovery

samsung-galaxy
build-issues

#1

Hi,

I’m trying to install /e/ on my Samsung Galaxy A5 2017 (with Ubuntu 16.04) but when I’m installing the custom recovery there’s a message of error at the end of the terminal (Between step 4 and 5). So, I cannot continued the installation. Someone has an idea what’s the problem??

Thank you :wink:

Kevin


#2

@rhunault this is an issue on a Samsung device. Do we have a solution for this.


#3

Have you tried it without heimdal via adb ?


#4

No, I followed the instructions and used heimdall


#5

Hi @FreeSpace,

Your Heimdall version is 1.4.1, last one is 1.4.2. I don’t know if it the cause of your problem, but I think it’s a interesting way to explore. Maybe you can try to get the last version. It seems it’s not possible to download it on the link in the documentation, and didn’t find it anywhere else.

It’s possible to install it from sources. Instruction are at the bottom of that page (“Appendix B - Installing Heimdall Suite from Source:”). I don’t know how you installed your current version, but maybe you have to uninstall it before installing the new one.


#6

I know heimdall from my Mac and it often fails. Best way installing twrp is via adb.


#7

You can try this , it’s worked for me on ubuntu 18.04 Last version of heimdall


#8

On windows i had a similar problem. It was solved by using the latest Heimdall.


#9

Thanks to all of you. I succeed in installing the new version of Heimdall. I haven’t tried again to install /e/. Do you some advice for the part “Installing /e/ from custom recovery” ? I’m not sure about what I must do.


#10

I’ve strictly followed the step by step install /e/ documentation here for a5y17lte. And i do not have encountered any problems.


#11

use adb and you will be happy :slight_smile:


#12

Hi,
I restarted from the beginning this morning and it’s worse than yesterday :weary:


#13

Do not have a Samsung device so just wanted to know if you need sudo access to run Heimdall? Have you access your device on this PC earlier through adb or heindall?


#14

No, I don’t need sudo access. Earlier with the previous version of Heimdall, I had no problem with that step


#15

I should try sudo too.


#16

The error on this page looks a lot like yours https://ubuntuforums.org/archive/index.php/t-1803296.html not sure the solution is complete.


#17

@FreeSpace You should read this too, and someone fix it running as root with sudo…, hope it can help…


#18

@e-media @Manoj @rhunault

I tried with sudo and that’s worked for heimdall print-pit but when I’m trying to install the custom recovery I found the same message and the same problem than yesterday. On the device, a white transfer bar appears fulled at 99%.


#19

Is it the right twrp*.img ?


#20

Yes, It’s the right one found here :
https://dl.twrp.me/a5y17lte/