New FP5 - easy-install fail?

Hello All,

I was very happy to receive my new FP5 until easy-install tells that my “FP5 is not taken in charge yet” (after configuring developer options etc.).

This surprises me as I read that easy-install is now ready for FP5. I used it to install /e/ on my current phone (Samsung Galaxy S7).

I uninstall / reinstall the snap package (i am a Linux user) to be sure I had the latest easy-install version. But I get the same result.

Any suggestion would be very much appreciated!


For the time being it’s back to not supporting FP5.


:iphone: New device support

Faiprhone 5 FP5"


Remove FP5 support."


support has been removed as some users report that it brick their device
if your installed securtity patch date (in settings → about the phone → android version → securtity patch date) is older than 2024-01-05 (included in e-1.20-t), you can try by youself using fastbboot :

1 Like

thank you @AnotherElk and @piero for your replies.

Isn’t it possible to use easy-install in some ways when the security patch date is before 2024-01-05 (my case: 2023-09)?

Any idea when the FP5 easy-install will be back?

Out of curiosity, does somebody know what happened with this very January security update?

A few days ago I killed my internal SD card with v1.2 update… I guess this is not my /e/week :'-)

1 Like

Did your Easy Installer show v-0.20 or v-0.21 in the very top of the window ? Edit you first tried the very old v-2.0, not a typo! :slightly_smiling_face: .

Of course we don’t know exactly why Easy Installer v-0.20 was withdrawn; there are preexisting Easy Installer issues[]=Easy-installer, maybe you hit one of those.

Once you get used to the differences Fairphone manual install look in many ways simpler than a Samsung.

For education, unzip the download and you can see and read the install script inside.

You would have to be very careful to look out for the differences between FP3 and your FP5, but this seems a nice intro to the Fairphone method. [HOW-TO] Flash /e/-OS on Fairphone 3 using Debian based GNU/Linux

v0.21 – but the first try was with v0.2 (initially installed in August 2021)

Thanks for suggesting the FP3 tutorial. I’ll compare and… maybe try!

Everything went well apparently.

Not surprisingly you gave me a very useful piece of advice @aibd : comparing with the FP3 manual was indeed very useful.

A big thanks to all in this community who make /e/os possible and always greater!


This topic was automatically closed after 90 days. New replies are no longer allowed.