New SMS, names not found

Hi :slight_smile:
I have a problem when sending a new SMS. If I open the SMS app and tap to write a new message not all of my contacts, or even all of the people I have previously sent a message to, appear in the list of names. Only the ones whose number is stored as “mobile” and not “main” are there.
This seems like a useful feature as sending an SMS to a land line will often not work. However, “main” contacts are the default and I do not always remember to change them when entering a new contact. Also, all of my contacts imported from my last phone have been imported as “main”, which was not even an option there.

Is it possible to change the settings somehow so that the sms app will also find “main” numbers? I think this is reasonable, my /e/ OS phone is my main (and only) phone and it can send and receive SMSs.

If not, is it possible to bulk reassign all the numbers in my contacts?

If not, can someone recommend a FOSS SMS app better suited to my requirements?


Hi @4nthony,

I saw that behavior and for me it’s a bug because even for work (which can be a mobile of course), you can’t find the number:

Good afternoon

1 Like

I have found the solution thanks to @petefoth in another thread :smiley:

From the SMS app:

  • Click on the “three line” menu in the top left
  • Click on settings
  • scroll down towards the bottom and deactivate “Mobile numbers only”

This should work for me. If it does not, I will report back :slight_smile:

1 Like

but whatever the value of this setting, any number which is a mobile phone should be displayed… whatever the type of number set (which can be like in your case set to another type)