New XDA app - highly questionable

I’m sure some of you use XDA Labs or some other forum reading app and found you couldn’t access the XDA forums. Newly revamped, it made current software immediately EOL.
Now they have their new app and it gives me zero confidence at the moment.

Before knowing it was available I saw this blurb…

Went to check it out. First off, it will only be available via the Play Store which makes some not too happy. Before getting to what the little article mentions here’s a few bits.
The XDA app has a long list of permissions it can use. Why? Don’t know. What else is the app supposed to do besides read messages.
It has 12 trackers not including the Facebook campaign tracking service and provider.

Like so many apps lately, to use the app you’re taken to the outside, via browser, to login and authorize first. As the little news bit mentioned, the app definitely goes all over the place.

Now there’s the part about where when you go into a thread and tap a VIEW button there are cases where it fails to do so.

Despite what the article said, that error I got on /e/OS Pie, rooted (trackers blocked except essential). On stock unrooted OxygenOS 11 everything worked, complete with friggin’ ads (clean, no ad or tracker blocking). So I’m not sure what’s what due to lack of detail in that bit.
Just because, I’ll be testing the app on my other ROMs just to see if they behave similarly.


Thx for this usefull post !!!

On five ROMs tested, three suffered from the SSL cert VIEW issue. Not just with threads, it also applies to other parts like viewing your profile.

Tesla Nougat and OxygenOS 11, the app worked. Though on Tesla I forgot to block trackers in the app (via App Manager). Once I did, the XDA app took a bit longer to start but took a really long time to bring up a VIEW. Almost thought it was frozen.
/e/OS Pie, Candy 7 Nougat, and Bootleggers Oreo suffered from the SSL cert thing.

Thought it was just me until I saw a review at the Play Store, authenticating via the web seems to only work reliably with Chromium-based browsers. Firefox and co. are a no go. Some webview-based browsers also failed to work.

This topic was automatically closed after 30 days. New replies are no longer allowed.