Newbie has problems with Redmi Note 8T

Hi there,
it’s my first attempt installing /e/ on a device and it’s a Redmi Note 8T.
I feel quite stupid and I am wondering whether you guys can offer me a quick support.
I have done all the necessary steps including step 4 from the manual:

Then when in step 5 it goes…

" 5. Temporarily flash a recovery onto your device by typing

```on some devices the below command may be required
```fastboot boot twrp-x.x.x-x-ginkgo.img
fastboot flash recovery twrp-x.x.x-x-ginkgo.img
After having downloaded the file
There are several images, such as vbmeta.img at 4 KB and dtbo.img at 8.192 KB and boot.img at 65.536 KB. Thus all that doesn't sound like I should flash any of these image files onto the phone. Furthermore I was asked to download the MI Flash application, whereas there is no further explaination given what to use this software for.

I'd be happy if you guys could help.
Thanks a lot!

**[Regain your privacy! Adopt /e/ the unGoogled mobile OS and online services](**![phone|80x80](upload://mtacZf1KIgDZJegjO3jnRNYJDPg.png)

Do you see 2 * No 5! :slight_smile:

You can only see these files (vbmeta.img, dtbo.img, boot.img, etc.) if you unzip this file But why do you do that?

This *.zip file must be installed according to the /e/ documentation as a whole, i.e. as a *.ZIP file using eRecovery via adb sideload

Simply follow the /e/ instructions and you will very quickly be able to enjoy your deGoogled Xiaomi phone.

OK. I had tried " Booting a custom recovery using fastboot"
Now I understand that instead I should use " Installing /e/ from recovery". When doing so, there also is a problem. The documentations says:

  1. In TWRP return to main menu, then tap Wipe
  2. Now tap Format Data and continue with the formatting process.

However The Main Menu Screen on the phone only says
Main Menu
MI-Recovery 3.0
Wipe Data
Connect with MIAssistant.

If I press “Wipe Data”
“Wipe All Data” and
“Back to Main Menu” show up.

If I press “Wipe All Data” and confirm, the process goes to somewhat about 2% and the screen shows
“Data wiped Successfully” and I can only go “back to Main Menu”.
There is no such thing as “Format Data” as shown in the documentary. :frowning:
Thus, I cannot execute the following steps
5. Return to the previous menu and tap Advanced Wipe.
6. Select the Cache and System partitions to be wiped and then Swipe to Wipe
7. Sideload the /e/ .zip package.

Thanks a lot for your help.

MI-Recovery 3.0 is not TWRP Recovery (!)

The first installation of TWRP Recovery requires an immediate confirmation of the installation. Immediate means that the user reacts in less than one second (!) If this confirmation of the TWRP installation is not achieved, Stock Android MI Recovery is automatically booted again.

1 Like

A little point. How did you get on with unlocking the bootloader?

Perhaps compare, another user suggests different route/different model: Xiaomi - Redmi Note 8 - ginkgo - Documentation Suggestions - #4 by Deano

I’ve just unlocked a Redmi Note8 took 178 hours for the unlock, worked perfectly.

Updated the install instructions as installing with TWRP didn’t work. Using the recovery did work.

Thanks @aibd @SuzieQ. I finally managed installing ginkgo on my device.
The phone doesn’t work yet, though.
After hitting REBOOT and SYSTEM in TWRP, the system reboots AGAIN into TWRP.
Same with REBOOT and RECOVERY, of course and REBOOT and BOOTLOADER -> FASTBOOT. With POWERBUTTON + VOLUMEUP/DOWN, the device only boots into TWRP or FASTBOOT.
I would like the device to boot into GINKGO. What can I do?

follow my updated instrcutions

Thanks to all the helpers and the developers in the community so far.

The reason for my problem was that I forgot to install the recovery image.
Furthermore it seemed, only the last string “fastboot flash recovery twrp-x.x.x-x-ginkgo.img” was helpful

I am excited about my new surveillance- free device. Yes!!!