Newbie having problems with installing on Samsung S7, device is not found

Can’t install on my new Samsung S7, with Easy-Installer, device is not found.

I am new here. Just want to use a phone that does not compromise privacy, and don’t want to support big tech…
I’m not too knowledgeable in IT, but not an amateur. Not knowledgeable about smartphones though.

If someone could help me beyond this first step I would appreciate it. Otherwise I will give up on e/OS/ and have to buy an iPhone, something I really hope to be able to avoid.

The Easy-Installer never finds the phone. Maybe it is because of this? - On Easy-Installer it says, one of the steps, “write debug in settings search bar”, “tap Android debug”, but my phone has no such option!
Tried Allow USB debug, but made no difference. The Easy-Installer does not find the phone, just goes on searching for it and nothing happens.

The phone is a model SM-G930F.

Am I doing something wrong?
Can someone help?

Hi @JeppeW,

What is your personal computer´s operating system ?

Thanks Piero, that was a fast reply, really appreciate it!
It is Windows 7.
I have a new computer, running W10, maybe I should use that?

That “debug” instruction issue will be addressed in a future version of the installer. Sometimes it’s called Android Debugging, sometimes USB Debugging. The new phrasing will make that clearer.

After you enabled USB Debugging on the phone, did you get a message on the phone asking to allow USB debug?

If not, did you confirm that the USB cable works for data transfer? Some cables can just charge the phone and are not sufficient.

Thanks Ingo,
That means I found the right option - USB Debugging.

There was no message. I just tapped on it, then nothing happened.
It seems it was allowed however, if I remember correctly there was a ‘switch’ in one of the menus for this and I checked it.

Not sure about the USB cable. Bought a used phone, in pristine condition but I know nothing about the cable. In fact I have never owned an Android phone and know nothing about them.

I see that my computer finds the phone via Explorer (not Easy-Installer), so I guess it must be a data-able cable.

I managed to get past that last step. Switched to a W10 computer.

Think I may have found a small bug in the installation guide, it says :
Installation, Restart device in Recovery mode.
It says you should press vol up, power and home at the same time. The drawing shows pressing vol DOWN, power and home at the same time.

The volume up way does nothing.
The volume down takes me back to the first screen.
I never saw a “teamwin” screen.
Tried skipping this step, just clicking Continue.
Then a new screen saying “Start device in Recovery mode”, with the same steps as above.
Gets nowhere.

I managed to get to a black screen that kind of looks like DOS, it says at the bottom "Fail to open recovery_cause…).

Trying again, gets to a screen with a robot, then the robot dies and it says “no command”. Weird. It’s a total mess!

No idea what to do…
Is it this difficult to install this for non IT-professionals? Then I am afraid e/OS/ will not become a serious alternative to the big tech phones.

This is supposed to be the EASY installer…???

eos operativ system för mobiler är skit

So disappointed… I really wanted a mobile that was free from spying, political interference, censorship and manipulation. Wish mobile telephony could be like that. Wanted to try e/OS/, bought a used Samsung S7, in pristine condition. Have tried all day to make it work through the “easy” installer. I just won’t work, no matter what I do.
I have searched forums, but found no help, because the matter is FAR TOO COMPLEX for a layman to understand. This is a task for professionals, those in the mobile phone development industry, for techies.

I could have bought a pre-installed e/OS/ mobile, yes. But the Easy-Installer was advertised as an easy alternative if you want to do it yourself, and it was a test - if this does not work ‘easily’ then I will not buy a preinstalled phone, because it will show the dedication of the people behind it to user friendliness. And even for a pre-installed mobile I know it won’t work just out of the box.

I realize now that I was naive. The e/OS/ system is not for normal people, those who just want to use a spyfree phone, maybe with a higher degree (than the boxed mobiles from the big two) of readiness to some personal engagement. But to this degree, I understand that this is a fringe movement. I got the impression from like youtube videos that this is the easiest to use system, and a real competitior to big tech. I was a fool.

It makes me sad. I realize there is no alternative (for normal people) to big tech.
I am seriously considering a dumb phone. Big tech disgusts me and I really wanted e/OS/ to work. But either it is a nerd-oriented system for hobbyists, or it is still too undeveloped and buggy to work for a wider audience but may one day become an alternative for the people. In any case, we are no there yet. This is a hint for the developers, if you read this. The idea is great, but you have failed, if the ambition was to bring this out to the people. Or you will have to work harder to make it work. I was ready to support you, but from what I have seen so far, it is far too early. Maybe someday. I hope so.

it is THE CRUTIAL STEP, @JeppeW, please be concentrate, it is THE CRUTIAL STEP :
press & hold
" volume down " + " power " button…
when the screen turns dark, immediatly press & hold
" volume down " + " home " + " power button…

Its done !

Ok Piero, thanks for trying to help me.
But I am confused, where is this? We have some different options. The screen below?
The installer also talks about these steps in the next (or so) screen, but not like you say, it never says “volume down” + “power” button…
At least from what I remember.
I’ll just have to try different alternatives, like last time…

By the way, I tried to turn off the phone at this step, because the installer says so. Then I get a prompt “USB device not recognized, failed…”…
But ok, I think you mean at the next step, because I always managed to get to the screen below and one step beyond it, when it starts a black DOS-like screen on the computer.
eos op problem 1

I think you mean at this screen below. This means that the Installer tells me different from you.
Ok, I’ll try your method, because I know following the Installer does not work.

Yep, tried it and it does not work. Are you sure about the button combinations you wrote?
Check what the Installer says in the photo,
I just get back to the blueish screen that says “Warning, a custom OS can…”, where you then press volume up to get to the Downloading screen.
Can’t get beyond this. What is “teamwin”? Something like a clock that counts to 100 appears sometimes. Then the phone restarts to a black screen that looks like a Bios setting screen, first option is “Reboot system now”, followed by “reboot to bootloader”, at the bottom there are white letters saying:
fail to open recovery_cause(No such file or diretctory)#
#Reboot Recovery Cause is unknown#
File-Based OTA
Supported API:3
#MANUAL MODE v1.0.0#
Successfully verified dmverity hash tree

Not sure what that means, of course, or if it is important. Neither do I know where things went wrong.
eos op problem 2

Two screens I get stuck on.
The second, not sure what that is, sometimes it gets stuck at like 92%, sometimes it moves on to another screen. Tried to get back to the black “DOS like” screen, but could not.
This is just crazy. Can’t stop, because I want to see how much more crazy it can get.

eos skit 2

“Can’t stop, because…”

How did you get on with the crucial step provided by @piero ?

Hi JeppeW!

I was in your shoes a few days ago, and in the end the solution was closer than I thought. The issue was that the guide provided here was simply not working for my phone (due to subtle model differences that render the guide useless in some cases), and it looks like the easy installer is also not working for you. The satisfaction when it finally worked was great and I hope you manage to sort it out with the following few ideas, without using the easy installer :

Is your phone rooted ? If yes, does your S7 have Exynos or Snapdragon CPU ? you can check this online easily by looking up the exact model in Settings>About Phone>Model Number = SM-93XYZ

If it’s Exynos and your phone is rooted, you can try to browse with your phone to the TWRP download page, download the latest .apk for your S7 phone and open the .apk file, which will start installing their app. Follow the app install instructions.
When that’s done, download the latest /e/ OS zip file from the this e.foundation website, and copy/paste it on the root folder of your phone’s SD card.

restart your phone in recovery mode with the magic power+vol down etc combo, which will start TWRP if you followed the app’s install instruction and it installed correctly.
Click on ‘Install’, and navigate to the /e/ OS .zip file on the SD card of your phone. If TWRP asks you to install anything else (SuperSu for example), decline. When you’ve selected the .zip and confirm the install, this should install /e/ on your S7.

Hope this might help

Even if you use Macrosoft OS on your PC, have a read to this guide :

Hi fs12345,
Thanks for your detailed try to help me!
Ok it sounds promising, you were in my shoes and now it works for you.
Yes it must be that the installer does not work for my phone. I have given up on it.

The next steps you mention sounds difficult, I have never had an Android phone and know absolutely nada about them.
Ok, I did some research and don’t know if it is rooted, but I would think not. I have not touched it, it is factory reset. What to do then, root it? I wonder if I would be able to do that…

One thing, which may be totally stupid, but does the phone have to connected? Mine is not online. I was hoping to do it without connecting it. I have an iPhone now and no intention to ever use Android with Google, I have no gmail and don’t want. After getting e/OS/ running, the plan was to insert my simcard and use it with my mobile operator. Was I wrong here?

Piero, I never got beyond the steps above.

And I am trying to use the Easy-Installer, are you talking about the, don’t know what to call it, the manual way using TWRP and Odin and all those things that seems incredibly complicated for a non mobile professional?
I am afraid I have no idea what they are talking about there: " from a terminal on the PC using the recommended adb sideload method", “unlock the bootloader, flash custom recovery”… And that is for a Linux PC? I don’t have Linux. That guide is totally incomprehensible for me.
I have been warned NOT to try to install with this method…

I was hoping it would work with the “Easy” Installer. If not, I will never be able to do it. Then, as I suspect now, e/OS/ is only for nerds of the telecom industry, not for normal people.

My intention is that you can understand what the easy installer is doing for you.
Please read the guide, and then, follow the easy installer steps, you will have success

The easy installer uses some low-level tools that can be executed manually, too.

What happens if you execute the following in a command prompt while the phone is connected via USB cable:

"C:\Program Files\easy-installer\bin\adb\adb" devices

Ideally this should detect your phone. And it should bring up the dialog that asks to permit access via USB debugging. As long as you haven’t got that dialog, you can’t proceed with any kind of installation, no matter if manual or with installer, not mater if /e/, CalyxOS or any other OS.

No problem, hope it might help.

you don’t need a SIM card in the phone for any of those steps, mine was inside but I started doing all of this in airplane mode so it didn’t make a difference.

It is definitely a bit tedious at the beginning, I’m an Android newbie like you and the hardest part for me was to realize that the guide didn’t apply to my LG G3 phone, then find ways to 1. root the phone, 2. install TWRP (a GUI appearing during reboot, that helps you wipe partitions/install new OS and more) as new recovery instead of the factory recovery partition, 3. wipe all data using TWRP then 4. Install /e/ OS from .zip, also via TWRP.

Hopefully in the near future there will be more video tutorials and demos to help go through those steps and make them a bit more accessible. good luck

Hi Ingo, thanks for trying to help!

I think the phone is detected. I managed the first part of the Easy Install, first time it downloaded something and every time I connect again it just says “your phone is compatible”.
I can get until that screen that asks for the magic power+home+volume (up or down?) trick.
That means means it has permission for USB debugging, or… ?

Tried the command line and it says:

  • daemon not running
  • daemon started successfully
    List of devices attached
    ce11160b0da4081904 device

No dialog was brought up. Not sure where that should happen?