Newbie having problems with installing on Samsung S7, device is not found

The easy installer uses some low-level tools that can be executed manually, too.

What happens if you execute the following in a command prompt while the phone is connected via USB cable:

"C:\Program Files\easy-installer\bin\adb\adb" devices

Ideally this should detect your phone. And it should bring up the dialog that asks to permit access via USB debugging. As long as you haven’t got that dialog, you can’t proceed with any kind of installation, no matter if manual or with installer, not mater if /e/, CalyxOS or any other OS.

No problem, hope it might help.

you don’t need a SIM card in the phone for any of those steps, mine was inside but I started doing all of this in airplane mode so it didn’t make a difference.

It is definitely a bit tedious at the beginning, I’m an Android newbie like you and the hardest part for me was to realize that the guide didn’t apply to my LG G3 phone, then find ways to 1. root the phone, 2. install TWRP (a GUI appearing during reboot, that helps you wipe partitions/install new OS and more) as new recovery instead of the factory recovery partition, 3. wipe all data using TWRP then 4. Install /e/ OS from .zip, also via TWRP.

Hopefully in the near future there will be more video tutorials and demos to help go through those steps and make them a bit more accessible. good luck

Hi Ingo, thanks for trying to help!

I think the phone is detected. I managed the first part of the Easy Install, first time it downloaded something and every time I connect again it just says “your phone is compatible”.
I can get until that screen that asks for the magic power+home+volume (up or down?) trick.
That means means it has permission for USB debugging, or… ?

Tried the command line and it says:

  • daemon not running
  • daemon started successfully
    List of devices attached
    ce11160b0da4081904 device

No dialog was brought up. Not sure where that should happen?

Ah, this is a good sign. No idea why the confirmation dialog never came, but as the second line contains “device” it doesn’t seem necessary (usually it would show “unauthorized” if you haven’t permitted access; “unauthorized” would be a problem).

If the installer says that your phone is compatible that’s also good. The files to be installed only need to be downloaded once. So consecutive runs of the installer won’t download again, i.e. this is not an indication of a problem. :wink:

I don’t have a Samsung myself so I don’t know about the steps that follow. But the installer creates a logfile each time it is executed. That might contain information where it hangs/can’t proceed.
Details are in Howto troubleshoot issues with the easy-installer

Thanks again fs12345, your advice has tempted me to try to try…
Was about to give up.
First, my phone is probably not rooted and its Exynos. It means I have to “root it”. No idea what it is or how to do it but I can research. Already checked briefly, seems difficult and dangerous but I have nothing to lose.

But I am hesitating at some of the steps. I’d like to ask, download the .apk file, do I have to do that from the phone, how did you do it, and all this, in flight mode? .apk is the installer for TWRP I would suppose. This could maybe be done from a PC, transferred to the phone and installed from there…(?)

From this step I would try the magic button trick that so far never worked, and TWRP should automatically start (and nothing else). From there I would navigate to a place in the phone where I had also previously downloaded the /e/OS file. (This /e/OS installer would also have to be downloaded from a PC and transferred to the SD card). If I understand correctly…

Ingo_FP_Angel,
I can only post once an hour or so, so I put two replies in one.
Thanks for your comment. I figured that I did not need to run the Easy Installer again and again, but I thought that there is some last step that did not work. I am not sure what the Installer is supposed to do after that, but I never advanced beyond the magic power+home+volume button trick. There should be something after this, right?
Yes there is a logfile, here is one after one of my attempts. I never got beyond this.

Ok, you are at the end of the point 6) of the guide : THE CRUTIAL STEP
Reboot to TWRP ( recovery mode )

/[HOWTO] install /e/ on a Samsung device from a GNU/Linux PC successfully

Yes the wifi was on, and using the browser you can navigate to the TWRP website and download an .apk file. When you go to your download folder on the phone, and tap this .apk file, it will be automatically recognized as an app that needs to be installed.
And indeed once this is installed, you can do the magic restart combo, and land on a screen that looks like this after recovery reboot : TWRP_sc

There you need to Wipe (clean cache + system iirc, this step matched what’s described on the /e/ installation guide for me), then back to the menu tap Install and browse to the zip you will have placed on the SD card…

the first step before all this would be to root, which on my phone worked with Kingoroot, who also distributes some .apks that you download and install, that will root the phone.

Sorry if some of the descriptions I give are a bit imprecise, I’m not so familiar with all the concepts and I’m a newbie, but I just spent 4 evenings on this and finally figured it out, and now have /e/ on my old LG G3 :slight_smile:

Rooting the phone is not needed for using /e/OS

Thanks again fs12345. You explanation seems to makes so much more sense than the pages on this forum. How come it seems much easier than on this page: https://doc.e.foundation/devices/herolte/install ?
There they talk about Odin, Heimdall, Installing a custom recovery, Installing /e/ from recovery, steps that I do not understand how they are related… Seems very complicated, involving installing several programs on a host computer and doing things that will certainly be a total mess if I try, like “install Heimdall and flash /e/OS”.

If I don’t need the “Heimdall” and all those, is it because I partially ran the Uneasy-Installer or did that accomplish nothing? I wonder what is the point of the Uneasy-Installer at all?
What I mean is, for you fs12345, were the steps you write about enough, no Uneasy-Installer and you did not need Odin and Heimdall?

If I am completely out of my depths here, please say “Jeppe, just stop and go get yourself a new iPhone”… I feel I have bothered you all too much already. I am thankful though for your will to try to help me so far.

Based on fs12345 logical steps and easy sounding tutorial, if I understand it correctly, these are the steps I should take:
Reroot with Kingoroot. Done from my PC with Kingoroot software.
Switch on wifi on phone, SIM card not needed.
Download /e/ from this website, save on phone SD card.
Go to TWRP website and download an .apk corresponding to the phone model.
Install TWRP, which should be automatically recognized.
Magic reboot with power+home+volume (not sure if up or down)
In magic screen, as in photo above, Wipe.
Tap Install on magic screen (which is TWRP I would guess)
Browse to SD card and install /e/ from zip,

If it works, celebrate! If not, continue to spam this forum with questions.
Completely different method from the almost totally incomprehensible tutorials in links above.

Piero, thanks again. Rerooting is not necessary?
That would be great. I don’t know in detail what it is and why it should be needed though. Something with administrator rights. If NOT needed for fs12345’s seemingly easy method above, then it would save some steps.
(by the way, I still don’t understand the point of your GNU/Linux link above, I understand nothing of what is written there…)

Hi piero, thanks for the feedback.

Indeed it seems that for the S7 it’s not necessary to root (cf guide), apologies if I caused any confusion for JeppeW.
It’s definitely needed for some phone models though, the first step of the guide for my model was this :

"Rooting your device

Important: The device must be rooted before proceeding any further."

1 Like

So the easy installer has already done most of the hard work.
Now it is waiting for you to restart communication.
Just concentrate on making that double switch.

fs12345, good, no reroot means one step less and one less problem.

So - based on fs12345 tutorial, without rerooting, these are the steps:
Switch on wifi on phone, SIM card not needed.
Download /e/ from this website, save on phone SD card.
Go to TWRP website and download an .apk corresponding to the phone model.
Install TWRP, which should be automatically recognized.
Magic reboot with power+home+volume (not sure if up or down)
In magic screen, as in photo above, Wipe.
Tap Install on magic screen (which is TWRP I would guess)
Browse to SD card and install /e/ from zip.

What I don’t get at all is the instructions on that page https://doc.e.foundation/devices/herolte/install
It is totally different from the steps above. Why is there something called Heimdall and then something Odin? From the fs12345 method these are not necessary (?).
The Heimdall step is for “preparing the installation”. Perhaps the Uneasy-Installer already did this.
Then there is the step “Installing a custom recovery”. Not sure what it does or if necessary in the fs12345 method.
Then there is the step “Installing /e/ from recovery”, which is installing /e/, but different from above, it involves using a PC (fs12345 don’t need that, I think), and something called “sideloading” on the PC. I see potential problems here.

aibd thanks but I tried the “magic double switch” and it never took me anywhere. It does not work.
By the way, does someone know what the Uneasy-Installer did - just checking for compatibility or actually installing or modifying something? It stopped working at the magic home+volume+power button step.

hi JeppeW,
again I was just describing the steps I took for my phone model, which differs from yours,
but I wanted to highlight that all the steps in the guide are not always necessary and/or can be performed differently when the recommended method does not work (e.g. twrp could not be installed via the method proposed, and similarly adb sideload did not work for me, so I copied .zip to SD then Installed from .zip, etc), and I was therefore hoping to provide a way to solve your particular problem that way. That said, I did not test those bypasses on an S7 but hopefully some of them can be applied to your case as well… I’m enthusiastic about /e/ and wanted to do all I can to help. all the best with this

fs12345 you’ve been most helpful.
Without you I would have given up now. I was so close many times.
Impressive that you could make this work without being a mobile industry insider, very impressive. It is much more difficult than I thought. If I had known I would never have started. This has taken me two days so far and I’ve felt really stupid and frustrated.
You’ve been good at explaining. Your method seems much more logical and easy.
(A tip to those who wrote that guide in the link above, it could be written so that it is easier to understand, now it is more like a short note for the author himself lest he forget some step…)

There are many different TWRP versions, if anyone has an advice how to find the right version, welcome to tell. Also, I actually don’t understand where to actually download /e/. Maybe here, but not sure why it says “dev”? - https://images.ecloud.global/dev/herolte/

I know it likely doesn’t help you with your installation efforts right now but I see a few things the installer does

  • it spares you reading lengthy/confusing installation instructions that all sound gibberish to non-smartphone manufactures/developers (ultimately you have to use tools for smartphone manufactures/developers to flash a custom ROM)
  • it spares you finding a working/not outdated tutorial in case you don’t succeed with the official install instructions
  • it automatically downloads all the right files you’ll need
  • it spares you the questions where/how to put/extract all the files and how to find them back
  • it keeps you from spelling errors when you type the commands (“normal” users don’t know how to work with the command line and usually there’s no need for them to learn it)
  • it keeps you from forgetting a crucial step or doing them in the wrong order
  • it keeps a log of what was executed behind the scenes and what were the results (which would hopefully help to identify the root cause if something doesn’t work as expected or help to improve the installer itself)
  • it keeps you from simply trying random stuff that makes things worse and might brick your phone

But it doesn’t (yet) solve all problems that might occur

  • missing/wrong drivers on the computer
  • using a charge only-cable
  • pressing the right button combination at the right time on your phone
  • permission problems on the computer OS
  • not following the instructions correctly that need to be done before the installer can pick up and do its work (allowing USB debugging/OEM unlock)

And of course - as any software - the installer might contain bugs :wink:

2 Likes

Thanks Ingo!

The question of what is the point of the Uneasy-Installer and what it may have done to my phone so far is important, because if I want to understand the remaining steps I need to understand what has been done so far.
A complete from scratch install is something I can just forget, as a non-mobile-industry-techie I can not expect to be able to do it, and I have been warned not to try.
IF the installer has already made some otherwise complicated steps for me, and just a few steps remain, I might try.
I am considering now if I should go ahead or give up. The logical thing would be to give up, this takes too much time and frustration. But giving up is admitting to defeat…

I am still not sure what to do, the more I research the more confused I get. The fs12345-method seems on a realistic difficulty level. But other pages show more complicated procedures, like here, for installing TWRP: https://www.leakite.com/how-to-install-twrp-30-on-samsung/
It says things like “If you want to flash via adb on your PC…”. And “Now grant root access, and run this last command…”, like it was the most obvious thing.

It seems following the fs12345-method, using a PC is not necessary.
The remaining steps should be: install TWRP, install /e/. All can be done from the phone, downloading via wifi and running from the phone. But can it be this ‘easy’?
If TWRP can be run and installed directly from the SD card, why use Odin or Terminal Emulator App…?

I don’t have a Samsung phone myself but from reading around here in the /e/ forum it seems sufficiently different from the phones I have, so this is mostly guessing now: from what I understood you always need an unlocked bootloader in order to boot into TWRP (or a rooted phone?). And to get an unlocked bootloader you always need some low-level tool like fastboot.
So I assume that only worked because the easy-installer already got you beyond the point of the unlocking step. Then it might be easier via TWRP and SD card. For those who have an SD card (slot) that is :wink:

Good idea! May I offer a little tutorial?

Nothing else connected.

Always find your way home:
From any of the 3 modes described here, press the Volume Down and Power buttons together for around 10 seconds until the phone restarts. Is “Soft restart” or “System boot”, expect to return you to your old phone.

Access Download mode:
If the phone is off, press and hold Power, Volume Down and Home buttons. (again, 7 - 10 seconds).
Use volume buttons to navigate.
Press correct volume button to enter Odin mode.
If you did nothing the Knox Warranty Void might be: 0x0 or (0x0000)
System status would be: Official / Current Binary: Official.
More likely you have tripped Sumsung’s “Self preservation” effort, and show (reading mine) Knox Warranty Void 1. Soft restart back to your phone.

Access Recovery mode:
Press and hold Power, Volume Up and Home buttons, perhaps over 10 seconds.
Read all the information, know your way home.
An unaltered “recovery” will be visibly Samsung.
TWRP, if installed already by Easy Installer, will show as “teamwin”. Soft restart back to your phone. or Swipe to Modify > Reboot > System.

Here is a random link to The Samsumg Community pages. https://eu.community.samsung.com/t5/other-smartphones/samsung-galaxy-s7-edge-stack-in-the-bootloop-odin-doesn-t-work/m-p/1265208/highlight/true#M36718. Check for more useful Samsung info on this site!

Good luck.

Ingo and aibd, thanks for your replies and your patience!
I wonder, shall I open another thread and continue there, to create a sort of How to install /e/ on Samsung Galaxy S7 for newbies ?
This thread has developed into so many directions and from my first attempt and failure you came with many new ideas. I am trying to sort it out and structure it now.

I can donate a sum of money to the foundation if we could get this to work.
I could also ‘hire’ someone to help me over mail personally and pay you per hour, if anyone is interested to do this.
Would very much like to make it work, but I am just a normal guy who knows nothing of the inside of smartphones, I run an old and awful iPhone SE and have never even owned an Android phone. I am way over my head here. But if someone like me could make this work then other could too. I know a bunch of people who would be interested in having an non-big-tech-phone. But we will need a method with the steps clearly laid out and explained in a non-techie way.

May I continue to ask, are there people out there, like me, who have managed to install /e/ from the Easy-Installer, and simple as that now runs it? If so it means it depends on the phone. In my case something is wrong/missing. It also means other people will run into trouble, like mine or different. This means there are things in the phone we must check before starting with the Easy-Installer, you can’t just take a factory reset phone and run Easy-Installer.

It exists :

The easy-installer will be a step by step guide