Newbie having problems with installing on Samsung S7, device is not found

I know it likely doesn’t help you with your installation efforts right now but I see a few things the installer does

  • it spares you reading lengthy/confusing installation instructions that all sound gibberish to non-smartphone manufactures/developers (ultimately you have to use tools for smartphone manufactures/developers to flash a custom ROM)
  • it spares you finding a working/not outdated tutorial in case you don’t succeed with the official install instructions
  • it automatically downloads all the right files you’ll need
  • it spares you the questions where/how to put/extract all the files and how to find them back
  • it keeps you from spelling errors when you type the commands (“normal” users don’t know how to work with the command line and usually there’s no need for them to learn it)
  • it keeps you from forgetting a crucial step or doing them in the wrong order
  • it keeps a log of what was executed behind the scenes and what were the results (which would hopefully help to identify the root cause if something doesn’t work as expected or help to improve the installer itself)
  • it keeps you from simply trying random stuff that makes things worse and might brick your phone

But it doesn’t (yet) solve all problems that might occur

  • missing/wrong drivers on the computer
  • using a charge only-cable
  • pressing the right button combination at the right time on your phone
  • permission problems on the computer OS
  • not following the instructions correctly that need to be done before the installer can pick up and do its work (allowing USB debugging/OEM unlock)

And of course - as any software - the installer might contain bugs :wink:

2 Likes

Thanks Ingo!

The question of what is the point of the Uneasy-Installer and what it may have done to my phone so far is important, because if I want to understand the remaining steps I need to understand what has been done so far.
A complete from scratch install is something I can just forget, as a non-mobile-industry-techie I can not expect to be able to do it, and I have been warned not to try.
IF the installer has already made some otherwise complicated steps for me, and just a few steps remain, I might try.
I am considering now if I should go ahead or give up. The logical thing would be to give up, this takes too much time and frustration. But giving up is admitting to defeat…

I am still not sure what to do, the more I research the more confused I get. The fs12345-method seems on a realistic difficulty level. But other pages show more complicated procedures, like here, for installing TWRP: https://www.leakite.com/how-to-install-twrp-30-on-samsung/
It says things like “If you want to flash via adb on your PC…”. And “Now grant root access, and run this last command…”, like it was the most obvious thing.

It seems following the fs12345-method, using a PC is not necessary.
The remaining steps should be: install TWRP, install /e/. All can be done from the phone, downloading via wifi and running from the phone. But can it be this ‘easy’?
If TWRP can be run and installed directly from the SD card, why use Odin or Terminal Emulator App…?

I don’t have a Samsung phone myself but from reading around here in the /e/ forum it seems sufficiently different from the phones I have, so this is mostly guessing now: from what I understood you always need an unlocked bootloader in order to boot into TWRP (or a rooted phone?). And to get an unlocked bootloader you always need some low-level tool like fastboot.
So I assume that only worked because the easy-installer already got you beyond the point of the unlocking step. Then it might be easier via TWRP and SD card. For those who have an SD card (slot) that is :wink:

Good idea! May I offer a little tutorial?

Nothing else connected.

Always find your way home:
From any of the 3 modes described here, press the Volume Down and Power buttons together for around 10 seconds until the phone restarts. Is “Soft restart” or “System boot”, expect to return you to your old phone.

Access Download mode:
If the phone is off, press and hold Power, Volume Down and Home buttons. (again, 7 - 10 seconds).
Use volume buttons to navigate.
Press correct volume button to enter Odin mode.
If you did nothing the Knox Warranty Void might be: 0x0 or (0x0000)
System status would be: Official / Current Binary: Official.
More likely you have tripped Sumsung’s “Self preservation” effort, and show (reading mine) Knox Warranty Void 1. Soft restart back to your phone.

Access Recovery mode:
Press and hold Power, Volume Up and Home buttons, perhaps over 10 seconds.
Read all the information, know your way home.
An unaltered “recovery” will be visibly Samsung.
TWRP, if installed already by Easy Installer, will show as “teamwin”. Soft restart back to your phone. or Swipe to Modify > Reboot > System.

Here is a random link to The Samsumg Community pages. https://eu.community.samsung.com/t5/other-smartphones/samsung-galaxy-s7-edge-stack-in-the-bootloop-odin-doesn-t-work/m-p/1265208/highlight/true#M36718. Check for more useful Samsung info on this site!

Good luck.

Ingo and aibd, thanks for your replies and your patience!
I wonder, shall I open another thread and continue there, to create a sort of How to install /e/ on Samsung Galaxy S7 for newbies ?
This thread has developed into so many directions and from my first attempt and failure you came with many new ideas. I am trying to sort it out and structure it now.

I can donate a sum of money to the foundation if we could get this to work.
I could also ‘hire’ someone to help me over mail personally and pay you per hour, if anyone is interested to do this.
Would very much like to make it work, but I am just a normal guy who knows nothing of the inside of smartphones, I run an old and awful iPhone SE and have never even owned an Android phone. I am way over my head here. But if someone like me could make this work then other could too. I know a bunch of people who would be interested in having an non-big-tech-phone. But we will need a method with the steps clearly laid out and explained in a non-techie way.

May I continue to ask, are there people out there, like me, who have managed to install /e/ from the Easy-Installer, and simple as that now runs it? If so it means it depends on the phone. In my case something is wrong/missing. It also means other people will run into trouble, like mine or different. This means there are things in the phone we must check before starting with the Easy-Installer, you can’t just take a factory reset phone and run Easy-Installer.

It exists :

The easy-installer will be a step by step guide

aibd, really appreciate your effort. I tried your tutorial steps.

Trying Access Download mode:
Checking, it says:
Current binary: Samsung
Warranty Void 0 (0x0000)
System Status Official

Trying Access Recovery mode:
Lots of information, it says among other things:
samsung/heroltexx/herolte
8.0.0/ lots of digits
At the bottom it also says lots of things:
#fail to open recovery_cause(No such file or directory)#
#Reboot Recovery Cause is UNKNOWN#
File based OTA
Supported API: 3
#MANUAL MODE v1.0.0#
Successfully verified dmverity hash tree

There is no “teamwin”.
(One option I am curious about: Reboot to bootloader ?)

It is the generic equivalent to the Samsung specific download mode…

.

Could I advise :
Boot the device in download mode,
Restart the easy-installer,

Follow the steps you have already done,
And after the easy installer have flashed TWRP, when you have to immediately reboot to TWRP, Try the four buttons to turn off the device and just release the “volume down” finger when the screen turns black, you will reboot in recovery mode.

.

If you decide to install manually,
Read my linux guide even if you follow the windows one

TWRP 3.3.x-x for installing /e/android Nougat-7, Oreo-8, pie-9
TWRP 3.4.x-x or 3.5.x-x for installing /e/android Q-10, R-11
twrp.img for heimdall
twrp.tar for Odin
Downloads : TWRP on the computer, /e/OS.zip on the SDcard

You have already done it because the s7 was shipped with android 6 Marshmallow, and yours is on Samsung android 8

Piero,
Thanks for those links. The first page was new to me, that is quite good!
I am checking it now, in my case, maybe since I have ran Easy-Installer partially I already have Odin. It seems I may have everything until TWRP.
I am checking that now. Just a bit confused about the many versions of TWRP for this very model, wonder if I should just select the top one, like if they are versions. Yes, checking, take the top of the list.
And wonder if any firmware updates are necessary for the phone of if I can just go… Let’s go.

By the way, that guide does not say where to download /e/ ROM. I suppose it’s to the phones SD card.
Aha, I continue and see that Odin in this case is also an application that you need to install on the PC. Will do.

TWRP downloaded. I did not know what SHA256 and MD5 was, but I researched and managed to check it. Downloaded on PC, the plan is to transfer to SD card, this is what you call “sideload”? No probably not.
Feeling like it is maybe not impossible after all. I am beginning to think this is fun!

Help… I have problems understanding this, what are Nougat, Orie, pie, Q and R… I probably should know, I have seen it, but not seen an explanation. I chose TWRP 3.5.0_9.0. Not installed yet. It’s a SM-G930F version phone, not sure if that matters. Something tells me that is wrong… How do I know?

Blockquote

TWRP 3.3.x-x for installing /e/ Nougat, Oreo, pie
TWRP 3.4.x-x or 3.5.x-x for installing /e/ Q, R
twrp.img for heimdall
twrp.tar for Odin

Blockquote

Will continue tomorrow. Kind of looking forward to it, with some trepidation… Thanks for your help so far!

I may be criticised for suggesting you reboot half way through your install, but I felt sure you are currently gearing up to start again! Why is reboot wrong during an install?

It is reliably reported that on reboot a clean and original Samsung phone will check both the areas you explored, Download and Recovery, and attempt to clean them of any non-Samsung material.

From what you report, your phone has done just that.

When you first want to use a newly flashed TWRP, you really don’t want to reboot, you are likely to lose TWRP.

That time you need to force stop but interrupt system reboot and boot into recovery.

You can actually now do a dry run of the button presses, with little risk, on your clean phone. Just merge the steps in my earlier tutorial!

Boot into Download mode, wait a moment.
Force stop [Power + Volume down + Home] get the timing right, so that the phone stops but does not start to restart; move fingers so that you change to “access Recovery mode”.

Edited for clarity.

Give yourself a gold star!

Thanks, I want the goldstar, but I don’t 100% understand those steps.
You say, start up into Download mode, but interrupt before Download starts by moving fingers to Recovery mode start?

By the way, Odin in the phone, that is something that Easy-Installer installed?
I think that Easy-Installer did not install TWRP. It stopped at the Download mode step.

By the way, what does this mean “And after the easy installer have flashed TWRP” ?

The easy-installer (beta version) is waiting for your intervention at this step ! … for two days,
it can flash TWRP in the ROM of your phone, but it can not press the buttons to reboot the device, it need the C.K.I. to do it.
( the Chair to Keyboard Interface, YOU ! )

Piero,

I saw in the comments in [HOWTO] Install /e/ on a Samsung smartphone with Windows easily] that someone also had the same problem I think - “error after trying to reboot to TWRP”.

I wondered what “flashing TWRP” actually means… I meant like - I think flashing means like erasing for putting in something else… But you would not do that to TWRP itself, it is a tool for “erasing” the original OS and installing a new one, or am I making a fool of myself now?

Negative, https://samsungodin.com/
With a reported Knox status of zero your phone is clean of anything from e/.

Ok, thanks. But Odin shows up in the blue screen, the Downloading mode.
I have an option there that says Odin something.

In Download mode you see “Downloading …”
I think it really means “Ready”, standing by for Odin.
… You have a lot of options!
When we flash TWRP, we are not technically installing into a running system.
We are replacing one recovery tool with another recovery tool, as you say, including erase.
Recovery will assist flashing a Custom ROM over an Original Rom, including erase.

I have successfully installed /e/ on my FP3 with the help of the easy-installer. But then, I had installed different OSes on different phones manually before that, so the general setup (drivers, functioning low level tools) was already working, which means I never ran into the problems that some users now face. Also, I knew at which point I had a small time window to press certain buttons on the phone. A complete newbie would likely still be reading the instructions (or better: trying to understand what they mean) while they should have pressed a button a second ago but then it’s too late and they’d need to start over.

Ideally, people like you could help make the installer better. By finding out why the installer always hangs at the same step.
But of course I can understand the desire to get /e/ on the phone and not spend more time and frustration on the installer. And that way, people in the past usually switched over to finishing the install manually. Which always loses the opportunity to improve the installer.

Ingo,
If I can help make the Easy-Installer better I would be happy to. My level of knowledge is way below yours, but maybe that’s useful. Yes, I was reading the instructions on the Installer and tried to make sense of them, specially at the step where it stopped. Not sure if it was my fault (don’t think so actually), like pushing the wrong buttons, no idea why it hangs there (up to where there should be a teamwin screen).
I guess I am now switching over to semi-manual installation as it seems the Installer has already done some steps, not sure what those where though, trying to find out.

Still don’t know why my phone has Odin in the Download mode screen. Perhaps one of the things the installer has done. But maybe it doesn’t matter. I’ll try to go ahead anyway.

Next steps should be:
Install Odin on PC
Connect S7 to PC via USB
Install TWRP via Odin
(mobile may need some drivers)
Start up TWRP on mobile
Do Wipe e t c on TWRP
Delete som files
Move /e/ install from computer to mobile
Install /e/ via TWRP
If no problems, finished!

I still don’t understand what is:
TWRP 3.3.x-x for installing /e/ Nougat, Oreo, pie
TWRP 3.4.x-x or 3.5.x-x for installing /e/ Q, R
twrp.img for heimdall
twrp.tar for Odin
Any link for more info or explanation is welcome!

Piero, thanks for clarifying under the image above. Yes it has been waiting for two days, but it seems it is waiting in vain, because it won’t work no matter what I do. It’s not difficult to push those buttons in that order, but even if I do - there is no teamwin screen. Something is wrong.

@JeppeW How has it gone for you? :black_joker:

aibd,
Thanks for asking. I am so thankful that you guys have tried to help me!
I had to work and no time to continue the installation. Have taken notes and thought about the installation process, realize how difficult this is for someone like me so gotta be totally methodical. The plan is to take it up again this weekend.
I am very motivated to make it work.