Newest version of SBB mobile?

Since yesterday I have a warning in the SBB Mobile app (Swiss Federal Railways) warning me that I will no longer be able to buy tickets next week with the version I have installed. No update is available yet in the /e/ App Store. How do I change this?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

/e/apps has always delayed updates. If needed, please Check with aurora store if an update for your app is available.

1 Like

Thanks, Piero.

I tried to download the last version from Aurora (I waited a few days hoping it would appear in /e/apps) but Aurora doesn’t seem to offer a newer version, either! Neither does Google Play. But I still have this error message in the app, saying I won’t be able to buy tickets anymore from next Monday if I don’t update. Is anyone else in the same situation? What to do?

Hoi Linda

I am using a Fairphone with e/OS. I did not observe the error you’ ve mentioned with the SBB app, nor where there any problems with updates from the aurora store (see screenshot of latest update).

Maybe you will want to try to unistall the app and then install the latest version from aurora store?

If this does not help: Where there any other changes in your phone that could affect payment by SBB app? Or probably the error message is misleading and the problem lies within the app itself?

Hi Edmund,

Thanks for your reply. That’s interesting. Did you install the app from /e/apps or from Aurora?

I think I will wait til Monday and see what happens. No, I am not conscious of any changes recently.

I installed SBB from the Aurora app store, which in turn I installed using f-droid - however, with e/os - Apps it (the Aurora app) should be the same.
Maybe you want to share some more information on your device? Which one do you use, and which version of e/os? And maybe you could provide the exact error message?

Yes, an App have to be updated using the same store that have been used to install it previously !

1 Like

Not strictly true (as far as I know). I believe the key point is that the update must be signed with the same key as the app you are updating.

F-Droid ship apps built and signed either by themselves or by the app developer. Updates from other stores won’t be signed with these keys so can’t be installed.

Aurora Store and /e/'s new App Lounge both get apps and updates from Google’s Play Store. (Only non-OSS apps in the case of App Lounge. they still get FOSS apps from, though they say they are planning to change and get them from F-Droid). So it should be possible to update an app that was installed from one of those apps using the other app, as they are getting the same updates, signed with the same keys.

The same may be true of /e/'s original Apps store: it gets all its apps and updates from, and nobody knows where they get the apps and updates from :slight_smile:

Having said all that, life is much simpler if you don’t use many different stores: I use F-Droid for FOSS apps and Aurora for the others. For apps that are available in both stores, I get the updates from F-Droid 'cos that’s where I got the apps. I don’t recall being offered updates by Aurora Store for these apps, but if I were offered I would decline, and blacklist the app in Aurora Store so updates are not offered there again.


Thanks everyone,

/e/apps actually suggested an update yesterday, which I installed. The error message was still there… But I tried buying a ticket today and it worked! Hope the problem solved itself.

Have a nice day

1 Like

Sali @Linda

Seems it was an programming issue: