Nextcloud - storage-directory on ext. sdcard -> solved by weird workaround

I’ installed for testing purposes /e/ (community-build, android 7.1.2) on my Galaxy S4 mini (GT-I9195). Before, I used the unofficial LOS 16 from developper “arco68”, xda. On LOS 16, it never was a problem to install the Nextcloud-app (from f-droid) and configure the storage-directory on external sdcard. When I tried same thing on fresh /e/-installation, something odd occured… I get the error message to miss the rights of writing to this specific location (ext.-sdcard)… Before, I correctly set up the ext.-sdcard as " portable storage". Now I found out, that it was necessary to let the system erase and format the ext.-sdcard a g a i n , AFTTER installing Nextcloud-app… Only then it was possible to direct writings on ext. storage, in my case the external sdcard…
'Hope this helps others with similar problem, as the internal storage of S4 mini is only ~ 4,5 GB after system-installation…

That’s an absolute normal way. A lot of apps which will need access to external SD will ask this question and you have to select the root of external SD to allow the access. This is a one time process.

Hello Harvey186,
…maybe I didn’t describe good enough the problem… Of course I’ m aware and familliar with apps asking for writing-permission on ext.-sdcard by popping up a file-manager-window, to point to root-directory through StorageFramework…
BUT Nextcloud-app didnt ask for that, instead I was presented 3 different directories on the internal storage, but none of the ext.-sdcard. THIS only happened after re-erasing/formatting the ext.-sdcard… In other words, the Nextcloud-app just don’t behaved like many other apps when offering possibility to write on ext.-sdcard…
Thanx for your answer,
I hope, I could clarify… :slight_smile:


Ah, ok, understand now. Will try on my own device

Just tried it with nextcloud app from f-droid. Works out of the box with my external SD