Nexus 5X LineageOS 17.1 to E - Stuck at Google Logo on Boot

Installed and ran LineageOS 17.1 Android 10 on the Nexus 5x for a few days just fine. Then I wanted to try e.

Tried adb sideload and TWRP install from adb push /data/local/tmp

Both approaches have same result. Reboot is stuck on Google logo. This is the same behavior if you twrp wipe all partitions and reboot. It’s acting like there is no OS.

This same phone ran e a few months ago just fine.

Reverting back to LineageOS is ok if I sdb sideload Reboot and it works ok.

I tried all image versions of for 5x on site with same result.

Any suggestions?

Hi @cburk350 downgrading to a lower OS causes such issues in most devices. The bullhead images are on Oreo. I am assuming you would need at the least a Pie version of OS to work. We do not have Pie builds of Nexus 5x at present. The upgrade of devices is in progress but no ETA’s. The LineageOS you are trying out and which work are they Oreo or Pie?

This issue Google Nexus 5X - “bullhead” could be similar to → Installing /e/ on a pixel 5.0 sailfish

When I understand right, you still have TWRP installed on your device.
So you have to wipe system / cache and davlik and format data.
Than reboot to TWRP and push the to your device
Than install it via TWRP

This way I was going several times on my MI5s

@harvey186 Tried this approach and it didn’t work. Thanks!

I think it has to do with what Manoj said. I’m going to try to reinstall stock rom.

Yes, I’ve found that if you install an android 9 or 10 rom then you need to flash stock android 8.1 before you can install android 8 custom roms such as /e/.

I’ve been through the process today. I can confirm that it stucks at google boot screen without flashing stock.

Have format data or only wiped ? Pls try with format data, reboot to twrp, push to device and flash it.

On Nexus 5x, flashing stock using Linux terminal (like I do with Linux Mint) keeps data. I don’t think this user has a specific e/problem. I think it is to do with unofficial software needed to run new os than nexus 5x is supported with.

90% of bootloops are coming from not formatting /data before flashing

1 Like

Ah, I haven’t formatted data to remove encryption on any of my devices.

If you change a rom you MUST format data. You can update or downgrade eOS or LOS or what ever custom rom without wipe/format data. But if you change the rom eOS to LOS or LOS to what ever custom rom you MUST wipe/format data

I do all the wipes except internal and never format data to decrypt data. I’ve never had a problem. Always works fine.

sure, you have. You stuck at bootloop :wink:

1 Like

Will try the next time I get stuck. Thanks for the tip!