Nexus 5X with Wi-Fi Calling Enabled - Is not working - Unable to text/call while connected to WiFi

I will mention that I did not test this out on the phone before installing /e/. I got it off of ebay, after seeing its IMEI is supported for WiFi calling with mint mobile, and immediately installed /e/ when I received it.

I found a spot in the house that has no cell coverage, so that I could test this feature. I’ve also ensured I have the feature enabled with my carrier. The same location in the house has great WiFi reception.

I’ve attempted to make a call, but it errors with: “Mobile network is not available. Connect to a wireless network to make a call.”

I am definitely connected to WiFi. I verified I could still browse the internet.

Does anyone have more information on getting this to work?

You bought your (used) Nexus 5X on ebay and didn’t check it for full functionality. This means that you lack the certainty that the phone is in good working order in terms of hardware.

Did you make a system back of StockROm Android after installing TWRP Recovery at the latest?

What StockROM Android firmware was installed on the Nexus 5X (6.0.0, 6.0.1, 7.0.0, 7.1.1, 7.1.2, 8.0.0 or 8.1.0) before switching to Google Nexus 5X - /e/ for “bullhead” * dev (oreo)?

It looks like your mobile SIM-card isn’t recognized, right? I also know this problem from some Samsung devices. As a first solution I recommend to reset your device within the TWRP-Recovery menu to factory settings → “Wipe Data/Factory Reset”.

Sorry, I meant to say open box, never actually used before. Never used with any carrier. But obviously not mint because they had to open the box to take a picture.

More important whether “used” or “new” is to make the device run smoothly.

1./ What StockROM Android firmware was installed?
2./ Have you already tried my first proposal for solution?

Thank you for the info @archie.

I will be trying your solution at an opportune time.

I did not make a system backup of StockROM and did not make note of what the original out of the box version was before I installed /e/.

However, I had to manually install a vendor image of 8.1.0 on it before it would properly boot to /e/.

I will be working on your proposal later, today.

Have you experienced Wi-Fi calling to work on the Nexus 5X with /e/, or know for certain that it does?

Thank you for your time.

That’s an important statement! That is what I was going for with my question.

With WiFi calling (“Voice-over-WLAN”) or VoLTE numerous custum ROMs based on LienageOS have problems, even if the provider supports these extended functions and a suitable tariff.

I would start all over again and test if the Nexus 5X with the current StockROM 8.1.0 can perform all desired functions flawlessly. Based on this it can be checked what custom ROMs are capable of.

Ok, thank you, @archie. I’ll do that.

Hi @archie, I’ve found instructions at to restore a full OTA image for my device. Is it ok, in your scenario you described, if I sideload the OTA image, or do I need to flash the factory image?

For reference:

Thank you

Hello @novacane your link at to res leads me to the error message “Page was not found”.

I would first install the last available facorty image “bullhead" for Nexus 5X” 8.0.0 Oero to ensure compatibility with /e/ for bullhead dev (oreo). You may also install version 8.1.0 Oero if 8.0.0 does not provide the desired result.

With these Facorty-Images all functions (WiFi calling, VoLTE) can be checked for proper function.

@archie, is sideloading the OTA acceptable for this testing? I see that as an easier option on the page.

@novacane, many ways lead to Rome and the important thing is, to start walking and not resigned…
You’re free to do whatever you think is right. I make here only suggestions for solutions.

Ok that makes sense. Thank you for your ideas, @archie

@archie, sideloaded stockROM just fine.

tested wifi calling just fine.

put /e/ back on it.

I have airplane mode on, wifi enabled, and wifi calling enabled. I’m able to make a call now.

I don’t get it, but it seems to be working.

Thanks for your time.

1 Like

Thank you for your pleasant feedback. Welcome to /e/ club.

You got it, @archie. Great to be here. The effort is worth it :smiley: nice feeling free.