Night light automatic turn on not working

Hi, on my Mido the night light feature gives me the day/night (white/black) menu theme, but the blue light filter that should turn on the same time isn’t working. The screen is constantly in the daylight (blue-ish) color tone. If i want to make it work i have to create manual schedule.
Anybody else having the same problem?

Hi, are you still on the test Pie build ?

If yes, what should be done is :

Settings > Display > Night Light :

  • Schedule : what you want (if sunset from sunrise doesn’t work, use custom time)

And you should also be able to see or add a “Night Light” toggle in the notification panel.

Hi, yes, I’m using a Pie test build. If I manually turn on Night Light, or make a custom time schedule - it works. I’m just wondering/asking since the phone obviously properly recognizes sunset/sunrise time and accordingly switches to the white/black menu theme, why isn’t the blue light filter using the same logic?

Or, to ask it the other way, by what logic does the phone know when to turn on/of Nigh Light? Is it GPS position (mine is mostly off), mobile operator/network time?

Actually the automatic activation of Night Light on sunset isn’t working for me neither, so I set custom time.
I think it’s because location is always turned off.

We can do a simple test. We turn on automatic activation, we wait until it’s quite dark outside and we activate location. If Night Light turns on, it uses location.

1 Like

Yes, that makes sense. Will try that today in the evening and post my results here. Thank you!

No, the Night light didn’t turn on after activating location. The result is same as before - the system theme changed to night mode, but not the Night light with it:

Same resulat, I will raise the bug on the gitlab.

1 Like

Hello.

It seems to work, for me (e-0.9-n unofficial), while set on A (automatic ?) from status bar…

Location is almost always set ‘Off’.

It might be specific to Pie then. Thanks

Works fine on MiMix2, latest official Pie.